Announcement

Collapse
No announcement yet.

MX Record when changing hosting provider

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MX Record when changing hosting provider

    Hi

    I have got a domain named demowolf.org (I made it up) with a hosting provider named providerAA.com and it is a registrar for my domain demowolf.org as well.


    I have changed my hosting provider from the providerAA.com to a providerBB.com but still the providerAA.com is a registrar for my domain (demowolf.org),,,,,, means I have not change my registrar.


    I have got Exchange server 2003 and AD and DNS are installed on the same server (Windows 2003). It has a private address: 192.168.0.50


    Name Servers for the old hosting provider (providerAA.com) are :

    NS1.providerAA.com = 202.45.67.89,,,,,,,,,,,I made up this ip address
    NS2.providerAA.com = 202.45.67.77,,,,,,,,,,,I made up this ip address



    Name Servers for the new hosting provider (providerBB.com) are :

    NS1.providerBB.com = 170.66.77.88,,,,,,,,,,,I made up this ip address
    NS2.providerBB.com = 170.66.77.88,,,,,,,,,,,I made up this ip address

    On our Exchange Server --> DNS Management Console --> our Server Name --> Expand “Forward Lookup Zones” --> I have got 7 records (I have not configured those records they were configured while ago ) :

    The first two {SOA and Name Server (NS) } I have got no problem with them

    The rest (5/7) I have got questions about them :

    Third record its name : ftp, type: host (A) , ip address : 202.45.67.89

    Fourth record its name : list, , type: host (A) , ip address : 202.45.67.89

    Fifth record its name : mail, type: host (A) , ip address : 192.168.0.50

    Sixth record its name : www, type: host (A) , ip address : 202.45.67.89

    Seventh record its name: (same as parent folder) , type : Mail Exchanger (MX) , Fully qualified domain name (FQDN) : demowolf.org, Fully qualified domain name (FQDN) of mail server : [10] NS1.providerAA.com. Is ( [10] NS1.providerAA.com ) supposed to be configured as a record value for [Fully qualified domain name (FQDN) of mail server ] ????? or this is wrong it should be something else because

    First Question
    I have a feeling the Fully qualified domain name (FQDN) of mail server should be : mail.demowolf.org. not [10] NS1.providerAA.com.,,,,,I need someone to confirm that ??





    After changing the hosting provider from old one to new one first thing I have to do : on the domain management panel (section) for my domain registrar (providerAA.com) I have to change name servers from NS1.providerAA.com , NS2.providerAA.com to NS1.providerBB.com and NS2.providerBB.com




    Second Question
    Do I need to change the ip addresses for the third, fourth, sixth records (not fifth) from 202.45.67.89 to 170.66.77.88,,,,,to be pointed from the old hosting provider to the new hosting provider ???? Or shall I leave them as its ? or Are they redundant (delete them ) ??


    Third Question
    I suppose the configuration for the seventh record [Mail Exchanger (MX) ]before changing the hosting provider is correct !!!!

    Do I need to change the Fully qualified domain name (FQDN) of mail server for the third record (MX) from [10] NS1.providerAA.com. to NS2.providerBB.com. ???? Or I have to change it to mail.demowolf.org. as stated in first question


    The reason I am asking that because of the below :

    http://www.siteground.com/tutorials/..._mx_record.htm

    If you have your domain name pointed elsewhere, but you wish to have your mail handled by your web hosting provider (e.g. SiteGround.com), you can easily achieve this by pointing your domain's MX (Mail eXchange) record to your host.
    To point your mail service to us, you should change your MX record of your domain to point to your server's hostname. For example, if your account is hosted on sitegroundXXX.com, then you should change your MX record to: sitegroundXXX.com.



    Fourth Question

    My networking setting is similar to the below :
    http://www.petri.com/configure_mx_re...il_traffic.htm

    When NAT is being used
    In cases where NAT (Network Address Translation) is being used you will need to provide them with the IP address of your external NAT interface, and configure your NAT device with Static Mapping for TCP Port 25, and have all TCP Port 25 traffic forwarded to the internal IP address of your mail server.
    Code:
    Domain name: dpetri.net
    Record FQDN 	Record Type 	Record Value 	MX Pref
    mail.dpetri.net 	A 	192.90.1.17 	
    dpetri.net 	MX 	mail.dpetri.net 	10
    I am confused why wasn’t a full stop (.) used is the code above while it is recommend in the below quotes ???
    http://www.petri.com/configure_mx_re...il_traffic.htm
    MX Records must be in the following format:
    domain.com. IN MX 10 mail.domain.com.
    And this quote as well
    http://www.siteground.com/tutorials/..._mx_record.htm

    Don't forget to put a dot at the end, otherwise the mail will not be pointed correctly.
    While in the example below does not use a full stop as well,,,,,,,,,,,,,,confusing !!!
    http://www.mike-tech.com/article.php...t4&article=114
    2. Choose MX Record from the "Record Type" list
    3. Leave the "Host Name" field empty.
    4. Type for example Mail.domain.com in the "Mail Exchange Server DNS Name".
    It'll be very useful if answers can be provided on part-by-part basis--quoting one of above part and answering it. I understand better this way.

    Thanks

    Thanks
    Last edited by zillah; 22nd August 2010, 06:50.

  • #2
    Re: MX Record when changing hosting provider

    Umm. Where to start?

    First. Your AD DNS entries are for your internal use. From what is shown, www, list and ftp are all hosted by providerAA while mail is hosted by your own server. You will need to switch those to providerBB. Talk to providerBB to get that done.

    Actually, do www.demowolf.org, ftp.demowolf.org and list.demowolf.org point to any services at all? If not, you can delete them from your AD DNS.

    Second. You have an MX record in AD DNS for your mail server, which is strange, in that you don't actually need that for internal client access.

    Try this:

    open up command prompt on your mail server
    type NSLOOKUP and press enter
    at the > prompt, type "server NS1.providerBB.com" without quotes, and press enter
    then type "set type=MX" without quotes and press enter.
    now type in "demowolf.org" without quotes and press enter.

    That should tell you what the public DNS entries are when it comes to email.

    You could also:

    type "set type=ANY" without quotes and press enter.
    type in "demowolf.org" without quotes and press enter.

    Which would give you more info about how we, on the outside, see that domain name presented and I would be hesitant to do much else without DNS being setup properly, as that can cause so many problems.

    Preferably we'd like you to talk with providerBB customer support to resolve this, since it certainly doesn't seem to be a test environment, and we cannot be held responsible if something goes wrong given that we don't know all of the facts.

    What I will say is that at some point, you will need to go into Exchange System Manager, open up the properties of your Default SMTP Server, go to the Delivery tab, click on Advanced, check the Fully-qualified domain name and Smart host values, as well as click on Configure to check what external DNS Servers are set.

    Those will most likely need to be changed from whatever they were for providerAA to whatever they should be for providerBB - and only they can tell you that.

    Comment


    • #3
      Re: MX Record when changing hosting provider

      Hi TokyoBrit

      Sorry for the late reply I was busy little bit.

      Your AD DNS entries are for your internal use
      Noted.

      From what is shown, www, list and ftp are all hosted by providerAA
      Yes.

      while mail is hosted by your own server
      Yes.



      Actually, do www.demowolf.org, ftp.demowolf.org and list.demowolf.org point to any services at all ?
      What do you mean to any services ?


      If not, you can delete them from your AD DNS.
      This is what I felt but I wasn't sure

      You have an MX record in AD DNS for your mail server, which is strange, in that you don't actually need that for internal client access.
      You meant this ,,,,,didn't you ?
      Fifth record its name : mail, type: host (A) , ip address : 192.168.0.50

      Preferably we'd like you to talk with providerBB customer support to resolve this
      Unfortunately they are not helpful.


      What I will say is that at some point, you will need to go into Exchange System Manager, open up the properties of your Default SMTP Server, go to the Delivery tab, click on Advanced, check the Fully-qualified domain name and Smart host values, as well as click on Configure to check what external DNS Servers are set.
      I will check that.


      Now every thins is working fine but I want to clear the mess.


      Thanks

      Comment

      Working...
      X