Announcement

Collapse
No announcement yet.

Exchange 2003 can send but can't receive

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange 2003 can send but can't receive

    Hi Everyone,

    I just put in exchange 2003 on Windows 2003 server. It seems it can send e-mails but can't receive any. I think it's a DNS error but I'm not sure.

    Anyone has had experience with this issue?

  • #2
    You need to make sure that external DNS servers know to send mail to your server by IP.

    Assuming your domain is "owned" by an ISP or hosting company, and that you are using a NAT router, you will need to put the external DNS of your network as an A record for a subdomain into their servers and also create an MX record pointing to that subdomain. Speak to support at your internet provider and they will probably talk you through it or do it for you.

    e.g. a mail.xyz.com 123.123.123.123
    mx xyz.com mail.xyz.com

    Also you will need to open port 25 on your router to forward to the internal IP of your mail server.

    I assume mail is bouncing, so I would send some test messages and check the headers to see where they fall down.

    Hope this helps a bit

    Tom
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      RE: exchange can send but can't receive

      Thanks Tom,

      This will point me towards the right direction. However, I'm a total newbie to exchange and DNS. I a little confused about adding the A records and MX records. Do I set that up on my server in the Windows DNS or at where my website is hosted?

      Comment


      • #4
        Hi NeoGeo,

        this is done on the internet, not your LAN, so it needs to be done where your domain is hosted. I would start by speaking to their techie people if you can and seeing what they will do for you.

        You will need a static public IP address to allow the mail to be forwarded correctly.

        All the best
        Tom
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Hi Tom,

          I thought it would be a DNS error. I will give that a try, the only thing that puzzles me is that I know i got to work before without doing any external dns work. for example i could send an e-mail to the server with [email protected] and the server would receive it. Maybe it was just a fluke. I'll give it a try.

          Thanks

          Comment


          • #6
            problem found

            Hi Tom,

            Thanks again for all your help. As it turned out, it wasn't any of my settings. The problem is in 2 parts, the first is I use comcast and they've put on a filter on port 25 that only accepted emails with ***@comcast.com.
            The second part is my my web hoster's server does not support direct domain, in other words I'm not allowed to send e-mails such as ***@123.123.123.123

            Well, it's been frustrating but at least i know what's going on now.

            Comment


            • #7
              Normally (at least with all the ISPs I deal with) you cannot have an MX record pointing directly to your external IP -- it has to be in two parts:
              a C record linking a "mail.xyz.com" subdomain to your external IP address and an MX record referring to "mail.xyz.com"

              I see no reason why this has to be so -- perhaps someone more up on DNS can explain it?

              Glad you seem to have it sorted (or at least tracked down). The port 25 filtering is astounding --- do Comcast not realise there are a few other domains out there?

              Tom
              Tom Jones
              MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
              PhD, MSc, FIAP, MIITT
              IT Trainer / Consultant
              Ossian Ltd
              Scotland

              ** Remember to give credit where credit is due and leave reputation points where appropriate **

              Comment


              • #8
                Re: problem found

                If your MX record is correct check your Exchange server. Make sure that you've allowed it receive email @yourdomain.com and not @servername.yourdomain.com. It defaults to @servername.yourdomain.com.

                Inbound tcp is commonly filtered because it's only used for SMTP servers.
                Alot of ISPs are now filtering it to reduce spam (unsecured open relays).

                You bypass filtered inbound tcp 25 by using something called mailhop. It allows you to route email bound for your domain to a non standard tcp port. It's available at http://www.dyndns.org

                Technically you don't need a static IP address. This is however depending on the circumstance for the hosting.

                An MX record is related to an A record not a CName which is to what I think Ossian was referring (C Record).

                Basically you create an A record for blah.yourdomain.com, then the MX record points to this A record. Using a sub domain isn't always necessary and is really only needed when the server hosting your mail is on different public IP address. If you only have 1 IP then you can create an A record for yourdomain.com, a CName for *.yourdomain.com allowing all sub domains to resolve to the same IP. Then create an MX record for that A record (yourdomain.com). If for example you have a NAT network and another server as your mail server you can direct traffic to it accordingly via your router.

                Run thru the Exchange setup wizard if you haven't already.








                Just a few more screens - I can't run all the way thru it again.
                Andrew

                ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

                Comment


                • #9
                  Telnet

                  Dan,

                  i can access the telnet feature connected to exchange

                  Comment


                  • #10
                    Before reading all the posts, I suspected that mail was being blocked by your ISP.
                    It happened to me not long ago. I had a mail server using mailenable; it was working fine!
                    During a weekend I upgraded to exchange 03. I noticed I couldn't send NOR receive outside my lan/domain.
                    After countless hours of headaches, I figured out that Bellsouth had started blocking port 25.
                    That was enough for me to change to another ISP.
                    Check your area for a smaller ISP and see what they offer you.

                    Comment

                    Working...
                    X