No announcement yet.

Earthlink blocking mail - mismatched rDNS

  • Filter
  • Time
  • Show
Clear All
new posts

  • Earthlink blocking mail - mismatched rDNS

    Hello all,

    Mails from one of my customers sent to any earthlink address is being blocked by earthlink. I've followed earthlink's automated procedures to solve the problem, but that hasn't worked. I've verified that my customer's mail server is not black listed anywhere, is not an open relay, and has a valid PTR record.

    My customer's mail server is:
    IP address of mail server is:

    I just heard from an earthlink level 3 tech support guy that the problem is that when earthlink (or anyone else for that matter) receives an email from someone at the norris group (my customer), the mail header "RECEIVED:" section indicates that the mail is from "" and not The issue is plainly obvious...the SMTP connection is coming from their firewall (which is and not the mail server (which is

    Right now, there is a 'A' record for -> The ISP (Charter) has created a PTR record for -> This can all be verified at any dns testing site.

    So...what do I need to do to fix this?

    Do I need to change the 'A' record for from to If so, then I'll need to have the ISP change the PTR too (obviously). I will also need to add a firewall rule which says to forward all incoming traffic on port 25 to the mail server's internal ip.

    Another option would be to create an 'A' called and resolve that to (the firewall). Then, have the ISP (Charter) create a PTR record to make resolve to THEN, I could update the helo response in the SMTP Virtual Connector to reflect instead of This would make the PTR, the Received, and the helo all match.

    Problem is...the mx record says that the mail server for is and not So...maybe I could then just add a CNAME record for which would just point back to

    So...what would happen if I then changed the MX record to

    Diagram of my customer's network:

    ISP -
    TheNorrisGroup's Firewall (Cisco 871) -
    Internal network gateway ip -
    Network Swtich
    Mail Server - Exchange 2003 (exchange.norris.local & internal ip of
    external 'A' record of which resolves to

    Any suggestions?

    Aaron Rogers
    Inland Empire Computing

  • #2
    Re: Earthlink blocking mail - mismatched rDNS

    If you have multiple IP addresses then you need to get your NAT corrected on the firewall, so the traffic comes out on the correct IP address. In many cases a firewall will accept email coming in on any IP address, but all outbound traffic will appear to come from the same default IP address.

    Correct that first.

    Otherwise you would need to change everything so that the host name and reverse DNS record match.

    Simon Butler
    Exchange MVP

    More Exchange Content:
    Exchange Resources List:
    In the UK? Hire me:

    Sembee is a registered trademark, used here with permission.