No announcement yet.

Difficulty configuring RPC over HTTP

  • Filter
  • Time
  • Show
Clear All
new posts

  • Difficulty configuring RPC over HTTP

    To give some background. I have configured RPC over HTTP for 6 of my clients with any issues. The 7th one is giving me problems. I have gone over the configuration (from and by the way these documents are excellent) at least three times checking everything and it all appears to be fine.

    When testing from I get the following response:

    Testing RPC/HTTP connectivity
    RPC/HTTP test failed
    Test Steps
    Attempting to resolve the host name in DNS.
    Host successfully resolved
    Additional Details
    IP(s) returned:

    Testing TCP Port 443 on host to ensure it is listening and open.
    The port was opened successfully.
    Testing SSL Certificate for validity.
    The certificate passed all validation requirements.
    Test Steps
    Validating certificate name
    Successfully validated the certificate name
    Additional Details
    Found hostname in Certificate Subject Common name

    Validating certificate trust
    The test passed with some warnings encountered. Please expand additional details.
    Additional Details
    Only able to build certificate chain when using the Root Certificate Update functionality from Windows Update. Your server may not be properly configured to send down the required intermediate certificates to complete the chain. Consult the certificate installation instructions or FAQ's from your Certificate Authority for more information.

    Testing certificate date to ensure validity
    Date Validation passed. The certificate is not expired.
    Additional Details
    Certificate is valid: NotBefore = 4/19/2010 5:22:48 PM, NotAfter = 4/19/2012 5:22:48 PM"

    Testing Http Authentication Methods for URL
    Http Authentication Methods are correct
    Additional Details
    Found all expected authentication methods and no disallowed methods. Methods Found: Basic, Negotiate, NTLM

    Attempting to Ping RPC Proxy
    Cannot ping RPC Proxy
    Additional Details
    A Web Exception occurred because an HTTP 404 - NotFound response was received from IIS6

    Following advice in other forums I have deleted the Exchange virtual directories and recreated them per this error but still no luck.

    When I try to log in using Outlook with the RPC profile I get asked for credentials, I provide them and then I get "Microsoft Exchange is unavailable".

    Prior to recreating the Exchange Virtual folders I would get the authentication box popping up over and over again.

    The setup is:

    Exchange server 2003 sp2
    Outlook 2007 running on Windows 7 (same platform I have used to configure and test other setup's).

    I have tried to log on both remotely and at the office and I get the same results so I have eliminated the firewall as an issue.

    The certificate is valid and from the same certificate authority I used for the other 6 sites.

    The only issue I see that is different is the internal name used on the certificate is the same as the internal FQDN and so is the external host name. I started to think it might be a DNS issue given there is a different public address and private address with the same host name (the only difference between this site and the other sites).

    I can access the server (e.g. and i get a page ("under construction")

    If I try to right click on rpcproxy.dll and browse I get an error about:
    "The page must be viewed over a secure channel"

    If I then add the "s" in the address (i.e. https) then I get:
    "The page cannot be displayed"

    The RPC is set up for Basic and NTLM authentication

    Otherwise I have set it up per the directions on "How can I configure RPC over HTTP..." article at this site.

    It seems like it has to be something simple I am missing.

    Any help would be greatly appreciated.


  • #2
    Re: Difficulty configuring RPC over HTTP

    Hi Mate,

    I don't think, test connectivity site is very good, it is good for troubleshooting though, but some times only.

    Come ack tou tour problem, could you tell us about exchange scenario and what error the 7th user is having when he/she tried to connect RPC?



    • #3
      Re: Difficulty configuring RPC over HTTP

      Sorry for the confusion on connecting the 7th site (not user). I was trying to let you know that I had done the RPC over HTTP at six other client sites and this one being the 7th. So I had done it before successfully a number of times - as it not being the first time to do RPC over HTTP.

      Exchange is a vanilla installation at this site. Nothing out of the ordinary. One domain, one email address. About 20 users, Blackberry Professional software installed on the same box for a handful of users.

      Basic error is the "Exchange server is unavailable" when trying to check name or make a RPC over HTTP connection.

      Is there anything more specific I can tell you to help diagnose the problem?

      It appears to be a simple connection issue although OWA works fine, Active Sync works fine (or did when I had an Active Sync user).

      I can ping the name (e.g. both internally and externally. So it appears to be there and asks for authentication (I'm not sure if Windows 7 asks for credentials before poking the exchange server or it is the exchange server asking for credentials...If the later then it can talk to the Exchange server it just doesn't like the credentials (I've tried domain\user as well as just user and I'm sure about the password) or doesn't like the protocol.

      Let me know anything specific I can relate to you.

      My gut tells me that it is something simple I am missing although I have gone over the installation a number of times and everything appears to be fine.

      Thanks for the help.


      • #4
        Re: Difficulty configuring RPC over HTTP

        Thanks for the explanation Bill,

        I am not expert in RPC/HTTP, But I recently configured this feature in my enviornment, and was having the same error,

        Please double check just one thing the RPC ports,

        if you're using CFG tool: type this command: rpccfg.exe /hd and see all domain names are correct with ports,

        or check directly from registery :
        HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxymake sure all ports are in right prder with netBIOS domain names, FQDN..use the following link for correct FQDN and NETBIOS names and their ports as per your exchange scenario:

        last thing: make sure GC is also have the RPC port. you need to add this key
        Locate and then click the following registry subkey:
        • Name the new registry value 'NSPI interface protocol sequences'.
        • Right-click NSPI interface protocol sequences, and then click Modify.
        • In the Value data box, type
        Let us know how that goes,All the best.RegardsSami


        • #5
          Re: Difficulty configuring RPC over HTTP

          Yes, the settings are correct (actually this is about the 5th time I've looked at them).

          I have a gut feeling it isn't in the mechanical setup (which is easy enough to check - and I have as mentioned above).

          I think it is something simple that I am missing or is not working correctly... All the settings are exactly as required in the various documents explaining how to set it up.

          Is there any way to check exactly where it is failing?



          • #6
            Re: Difficulty configuring RPC over HTTP

            there is a RPC ping tool, you need to google this, and try to ping rpc connectivity,

            another thing, I gone through below test connectivy logs again, and its seems you have a problem with your IIS directories.




            • #7
              Re: Difficulty configuring RPC over HTTP

              You are getting a certificate error.
              That is enough to break the feature. If there is any kind of error then the feature fails. It either works, or it doesn't.

              You need to ensure the certificate trust is built correctly. You haven't said who issued the certificate, but something is wrong there somewhere.

              The 404 is also a bit of a concern.

              Personally I would remove the RPC Proxy feature, the two virtual directories and run IISRESET.
              Then reinstall the RPC Proxy fresh and do the registry keys correctly.

              RPC over HTTPS fails for one of three reasons:
              1. Trust on the certificate.
              2. Mismatched authentication type
              3. Registry settings incorrect.

              Of course presuming that the server meets the requirements.

              Simon Butler
              Exchange MVP

              More Exchange Content:
              Exchange Resources List:
              In the UK? Hire me:

              Sembee is a registered trademark, used here with permission.


              • #8
                Re: Difficulty configuring RPC over HTTP

                Thanks for the heads up on the certificate. It appeared as a warning so I ignored it. There was a problem with the certificate which I worked out with the certificate authority and the settings in the 2003 server.

                I now get through the certificates with no errors or warnings on the Microsoft test but still get hung up on the 404 pinging issue ("A Web Exception occurred because an HTTP 404 - Not Found response was received from IIS6 ").

                I will take your advice and remove the RPC proxy, which two virtual directories are you referring to? I will then do the iisreset and the RPC proxy and check all settings and see if it resolves it.

                Thanks again for the advice.



                • #9
                  Re: Difficulty configuring RPC over HTTP

                  The RPC Virtual directors should be RPC and RPCWCert or something like that.. and by default normally would exist below the default website
                  Please do show your appreciation to those who assist you by leaving Rep Point


                  • #10
                    Re: Difficulty configuring RPC over HTTP

                    OK, I fixed the certificate issue.

                    I uninstalled RPC then deleted the directories, then reset iis and then re-installed rpc over http.

                    I used the utility mentioned in the article and it set up the registry entries.

                    When I try to connect it asks for my user name and password. I give it and then it pops back up and asks again ad infinitum...

                    I have replaced the rpcproxy.dll file, made sure the Web services pointed to the right location and the file was there.

                    When I right click on rcpproxy.dll and try to browse it gives me the security alert and asks if I want to proceed. I click yes and receive a blank page.

                    I finally deleted the profile I was trying to use (even though it all looked fine) - created a new one and it worked!

                    I wonder if it was a bad profile from the beginning???