Announcement

Collapse
No announcement yet.

Cisco Router and exchange 2003

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco Router and exchange 2003

    i have cisco router connected to a 2 meg line, the router is set to allow 10.10.10.4 to be exposed to the net. I have setup excahange and it will send mail fine? but i cannot recive? i have a webname and the mail is going and it's from the correct name just will not recive? do i forward the website to my fixed ip?

    say my name is test.co.uk
    would i change the mx record to mail.test.co.uk or mail.76.45.45.34.co.uk
    or would i just put my ip in the record?

    any help would be great

    thanks

  • #2
    Re: Cisco Router and exchange 2003

    What is your MX record set to at the moment ?

    Try and telnet to your server on port 25 from an external connection.

    topper
    * Shamelessly mentioning "Don't forget to add reputation!"

    Comment


    • #3
      Cisco and the Exchange Server

      Peppereyes,

      I am a little confused by a couple of things you said, such as "the router is set to allow 10.10.10.4 to be exposed to the net" but it might help if I describe how I have my Cisco 1720 and my DNS set up.

      The way I have my Exchange server "exposed" to the internet is through NAT. Assuming the server is at IP address 10.10.10.4 (to use your numbers), the outside WAN address is xxx.xx.xx.xxx, and NAT is enabled. I would have the following lines in my Cisco configuration:

      ip nat inside source list 1 interface Serial0 overload
      ip nat inside source static tcp 10.10.10.4 25 xxx.xx.xx.xxx 25 extendable
      ip nat inside source static tcp 10.10.10.4 443 xxx.xx.xx.xxx 443 extendable
      ip nat inside source static tcp 10.10.10.4 1723 xxx.xx.xx.xxx 1723 extendable
      ip nat inside source static tcp 10.10.10.4 3389 xxx.xx.xx.xxx 3389 extendable
      (fill in the XXXs with your own IP address)

      You'll notice I have port 25 open for incoming email traffic, port 443 for SSL traffic (Outlook Web Access), port 1723 for PPTP, and port 3389 for Terminal Services.

      At my DNS servers for the domain name (I use ZoneEdit.COM for free) I have an A record for SMTP.testdomain.COM pointing to "xxx.xx.xx.xxx." I have an MX record pointing to "SMTP.testdomain.COM" (I also have an MX record pointing to a backup mail server, just for safety.)

      Incoming mail servers resolve the MX record to "SMTP.testdomain.COM" which in turn resolves to "xxx.xx.xx.xxx." The telnet request from an outside SMTP server hits the outside WAN IP of my Cisco 1720, and the Cisco recognizes that it is asking for port 25. Because I am using NAT, it sends all incoming port 25 traffic to my mail server at 10.10.10.4, and the Exchange server answers up with a friendy "Who the hell are you?" (I'm using SPAM blocking)

      Perhaps I'm "preaching" to someone who already knows this (forgive me if I am) but, if you have somehow made an MX record that erroneously points to 10.10.10.4 - then there is no way you could possibly ping it or Telnet to it from the outside. The IP 10.10.10.4 is "invisible" on the internet.

      If you are connected to the Internet on another PC from the outside of your router, and were to type from a Command prompt, "Telnet 76.45.45.34 25" (and assuming the IP of the outside of your router, or the exposed IP address of your mail server was 76.45.45.34), then your Exchange server should answer up as well with it's own friendly greeting. If you can't manually Telnet to your mail server, then neither can anybody else.

      If you are successful with "Telnet 76.45.45.34 25" but NOT successful with "Telnet SMTP.testdomain.COM 25" then you have a DNS problem.

      If you can manually Telnet using port 25 to your mail server IP address, but still can not receive mail or telnet to the MX record name, then your problem is at the DNS server. You must have the MX record pointed at the correct IP address, or at a host name that resolves to the correct IP address.

      The question about how to enter the information in your DNS server depends on your DNS server.

      I have found that ZoneEdit.COM is an EXTREMELY simple service to use and understand, and the price is right - FREE for the first 5 domains. Try setting up an account there and experimenting to see if it suits you. It also might help make DNS records easier to understand.
      TTFN
      Rex Derby

      Comment


      • #4
        problem

        i have now solved the problem thanks guys

        Comment


        • #5
          Re: problem

          Originally posted by peppereyes
          i have now solved the problem thanks guys
          Maybe you could let us know more info about what you did to solve the problem, so if someone else has the same problem they may search and come accross this thread?
          Server 2000 MCP
          Development: ASP, ASP.Net, PHP, VB, VB.Net, MySQL, MSSQL - Check out my blog http://tonyyeb.blogspot.com

          ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

          Comment


          • #6
            how i solved the problem

            i went ot my website host and entered my ip address in the forward section so my website points at my ip and then put the same ip in the ANAME box and MX box so the external DNS servers know where to look for my site and the MX and ANAME records. the mail server works fine.

            I need to get the webmail part working now but when i do i'll make a full guide with screen shots to help the other users.

            so say your site is named test.co.uk and you have a a adsl line with fixed ip of 50.50.50.50?

            1 login into your website control paniel and in the administer site section there will be an option for DNS

            2 select the forward option and point your site to your own IP address in this case 50.50.50.50

            3 now in the mx and aname record section enter the ip address again 50.50.50.50 and save the changes, if you get a free site with your provider you will see your site name (don't worrie thats normal)

            4 after a 24 hours goto https://www.mailcontrol.com/utility/....mhtml?domain= and enter your domain name in this case it was test.co.uk and run check to see if the result comes up with your ip if yes then your exchange will work as long as you have the correct post open.

            hope this helps

            Comment


            • #7
              Thanks peppereyes, i hope this helps someone in the future.
              Server 2000 MCP
              Development: ASP, ASP.Net, PHP, VB, VB.Net, MySQL, MSSQL - Check out my blog http://tonyyeb.blogspot.com

              ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

              Comment


              • #8
                Basically the problem was the MX record was pointing to the wrong IP address.

                For mail flow to work correctly users on the outside world need to know what the IP address is of your external interface on your router. To do this the exchange server will query DNS and ask if it has the MX (Mail Exchanger) record for your domain. DNS will hopefully resolve the IP address and then try to create a connection to your exchange box directly using the IP given by DNS.

                The next step in the process, presuming you have your exchange server behind a NAT router, is to port forward port 25 to the internal address of your exchange server to handle the requests.

                Comment

                Working...
                X