No announcement yet.

ActiveSync and Exchange 2003

  • Filter
  • Time
  • Show
Clear All
new posts

  • ActiveSync and Exchange 2003

    I have been going around and around with ActiveSync and Exchange 2003. What is supposed to be simple and straightforward to set up is instead a never-ending series of obstacles and surprise problems.

    Here’s what I have: Windows 2003 SBS and Exchange 2003. I have ActiveSync 3.8 on an XP Pro w/s on the domain. I installed the Update for Windows Server 2003: KB831464 , applied Exchange 2003 SP1, and followed up with the Update for Exchange 2003 (KB 883543).

    The mobile services are all enabled in the Exchange System Manager. The “per users” settings are also enabled. OWA works just fine with both HTTP and with HTTPS. I finally got OMA working as well with both HTTP and HTTPS. The firewall has ports 80, 443, and 1723 (for PPTP) open and pointed at the exchange server.

    The ROOT certificate is installed on the PocketPC 2003 device, and from the outside of the network it connects just fine via HTTP (port 80) and HTTPS (port 443) to the server – https://serverFQDN/exchange and https://serverFQDN/oma. The certificate name matches the FQDN of the server and there are no errors. I can also establish a PPTP link via VPN from the PocketPC 2003 device as evidenced by a successful PING of other PC names inside the firewall – SERVER2, SERVER3, and my own PC.

    I tried it at first without SSL on OMA just to keep it simple – one disaster at a time – but that didn’t help. I followed the directions in “Configure OMA to use SSL” and then followed the directions in Method #2 of “Problems in Synchronizing a Pocket PC with Exchange Server 2003 when using SSL.” That completely screwed my access to OMA but OWA still worked, so I applied the update, exchSP1, and post-update again. Both OWA and OMA are working again.

    So as to simplify things (and to prove that wasn’t the problem), I unchecked the “Require SSL to connect” on the entire Default Web Site.

    I do not have forms based authentication enabled – I didn’t want to confuse an already bad situation.

    At every step, before trying the next thing, I have tested and re-tested. I have had a parade of errors in the past, but have eliminated them one by one – until now. Even after bringing the cradle in to work, plugging in and creating a standard relationship with the w/s and with the exchange server with the right name, password and domain – it still won’t sync with the Exchange server. I get the Error Code: 0x80004005. Resetting the device does no good. I have tried ActiveSync both with and without an SSL connection.

    So, I’ve done just about everything possible, and still no joy. Anybody want to wade in on this one?
    Rex Derby