Announcement

Collapse
No announcement yet.

Windows 7 RPC no HTTPS

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 7 RPC no HTTPS

    Please help - with this issue.

    Situation : Exchange server 2003 setup for RPC over HTTP (no HTTPS)

    Working on windows XP and Office 2007.

    New PC has Windows 7 and cannot connect to Exchange over HTTP.

    Windows 7 pc is a remote pc with no VPN access and not on Domain.

    After trying for two days searching forums for a solution I decided to load Windows 7 XP mode (vitual pc).

    Installed Outlook in XP mode and connected to Exchange with no errors.

    Now if Outlook 2007 can connect with no SSL in XP mode (on the same PC) then why can it not connect in Windows 7.

    I cannot download the Cert for the exchange server as it is disabled and port 443 goes to another server on the Domain.

    Is there some registry fix that will allow this to be done?

    Shane

  • #2
    Re: Windows 7 RPC no HTTPS

    We have PCs in the office not on the domain for Remote Support, and I have Outlook 2007 with RPC over HTTPS installed on Windows 7 Enterprise x86 with no issues. No reg tweaks etc, just set it up and installed the cert and it worked.

    Any errors in the logs etc? Also check out Daniel's troubleshooting articles on the main Petri site knowledge base, lots of good stuff there.
    BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
    sigpic
    Cruachan's Blog

    Comment


    • #3
      Re: Windows 7 RPC no HTTPS

      First thing - As I said in first post. I do not have access to the Cert as we never used it before. We are running RPC with HTTP only.

      Funny thing is after trying again for the 50th time and just leaving it for an hour "trying to connect" it did.

      With XP it connected instantly- with Windows 7 it took an Hour before it made connection.

      Maybe it could be Avast - will never know until I install the next Laptop.

      So to others having the same problem - be patient

      Shane

      Comment


      • #4
        Re: Windows 7 RPC no HTTPS

        ok - i see your point in that it was never used before..but.. why does that mean you can't access the cert ?
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment


        • #5
          Re: Windows 7 RPC no HTTPS

          Not the domain admin and port 443 goes to another server on the domain.

          since i can not logon to the server - i cannot get the cert.

          never needed it before - so it was never an issue.

          Comment


          • #6
            Re: Windows 7 RPC no HTTPS

            I only mentioned the cert as I wanted to detail all I had to do to get it working, I'm aware you don't need it unless you're using HTTPS.
            BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
            sigpic
            Cruachan's Blog

            Comment


            • #7
              Re: Windows 7 RPC no HTTPS



              On second look I have noticed it is not working. It is connecting on TCP only not HTTP.

              So i still need a solution.

              Comment


              • #8
                Re: Windows 7 RPC no HTTPS

                I may be missing something but how are these two possible in your scenario?

                "Windows 7 pc is a remote pc with no VPN access and not on Domain."
                "On second look I have noticed it is not working. It is connecting on TCP only not HTTP."
                cheers
                Andy

                Please read this before you post:


                Quis custodiet ipsos custodes?

                Comment

                Working...
                X