No announcement yet.

Problem running ForestPrep or Removeorg in Exchange 2003

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem running ForestPrep or Removeorg in Exchange 2003

    In my original install of Exchange 2003 organization, I ran ForestPrep on the forest root domain controller, and then ran DomainPrep and installed on each of two Exchange 2003 servers.

    When attempting to remove the organization, Removeorg was run from one of the Exchange servers that was installed.

    Now when I attempt to run ForestPrep from the forest root, I get the following message:

    The component "Microsoft Exchange Messaging and Collaboration Services" cannot be assigned the action "Install" because:
    - To install the first Exchange server in a domain, or to run setup in "/ForestPrep" mode, You must be an Exchange Full Administrator at the organizational level. You must use an account that has been granted the Full Exchange Addministrator role on the Exchange organization using the Exchange Administrative Delegation Wizard.

    Attempting to run RemoveOrg gives me an identical error.

    I have tried to run RemoveOrg and ForestPrep on all three of the servers with no success. In addition, I checked ADSIEDIT and my account has full control. I am a member of Schema Admins and Enterprise Admins.

    Any help would be appreciated.

  • #2

    You may need to remove the Exchange org. manually:

    Note: You should backup the DC's and the Exchange servers before using
    this kb.
    Best Regards,

    Yuval Sinay

    LinkedIn:, Blog: