Announcement

Collapse
No announcement yet.

[win2k3 + Exch 2k3] Exmerge Export problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [win2k3 + Exch 2k3] Exmerge Export problem

    Hi all,

    I've tried to user Exmerge to export mailboxes from our Exchange 2003 server, but am running into problems.

    Here are some details on our setup:
    • Windows 2003 Standard Server SP2
    • Microsoft Exchange Server 2003 version 6.5 (Build 7638.2 Service Pack 2)
    • Logged in as Administrator account
    • Part of an AD environment
    • Running Exmerge as Administrator on the same server where Exchange is running.
    • This server is also DC for the domain.

    I've made sure that on the mailboxes I'm trying to export I have full control, no send as/receive as deny [also not from parenting groups, I've set all the possible denies to allows], on the Exchange Server, the Storage Group and Exchange Environment all have full access as well.

    Yet when I try to run Exmerge I get an immediate failure when trying to export one of the mailboxes.

    The Exmerge.log is set to maximum logging and shows me the following error:

    Code:
    [16:21:47] Copying data from mailbox 'AM-Boekhouding' ('AM-BOEKHOUDING') on Server 'W2K3OFFICE' to file 'F:\SYSTEEMBEHEER\TEMP\AM-BOEKHOUDING.PST'.
    [16:21:47] DN of object is '/O=SHIELD MARK/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=AM-BOEKHOUDING'.
    [16:21:47] Entered Routine:  (CMapiSession::MapiInit)
    [16:21:47] Successfully initialized MAPI.
    [16:21:47] Ending Routine:  (CMapiSession::MapiInit)
    [16:21:47] Entered Routine:  (CMapiSession::CreateEMSPSTProfile)
    [16:21:47] Error creating Message Service (MSPST MS) (CMapiSession::CreateEMSPSTProfile)
    [16:21:47] Ending Routine:  (CMapiSession::CreateEMSPSTProfile)
    [16:21:47] Errors encountered. Copy process aborted for mailbox 'AM-Boekhouding' ('AM-BOEKHOUDING').
    [16:21:47] Entered Routine:  (CMapiSession::DeleteOurProfile)
    [16:21:47] Ending Routine:  (CMapiSession::DeleteOurProfile)
    [16:21:47] Ending Routine: EDKRoutines::CopyMailBoxData)
    [16:21:47] ((Thread0)) CopyMailboxData Failed -AM-BOEKHOUDING
    [16:21:47] ((Thread0)) Incremented progress bar
    [16:21:47] Number of items copied from the source store for all mailboxes processed: 0
    [16:21:47] Total number of folders processed in the source store: 0
    [16:21:47] 0 mailboxes successfully processed. 1 mailboxes were not successfully processed. 0 non-fatal errors encountered.
    The folder where I'm trying to export to exists and I have sufficient rights to this folder. Even changing to another disk/folder/server doesn't affect the export.

    The mailbox I'm trying to use at the moment is only 652KB of size, but that's one of my test boxes. Once this is working I have various large sized mailboxes to export, so manually doing this in Outlook client is not really an option.


    I've double and tripple checked the permission structure on the server, I have also added the following registry key to the registry:

    Code:
    HKEY_CURRENT_USER\Software\Microsoft\Exchange\ExAdmin\ShowSecurityPage
    Data Type: REG_DWORD
    Value: 1
    Which has allowed me to see some more of the security tabs which I have then changed, but unfortunately no luck.

    I have checked Petri.co.il [of course], Experts-exchange.com, google, local forums and all, but I keep getting referred to "send as/receive as" permissions, but am unable to find out where those might still be.
    As far as I know I've changed all the permissions to match what they should be, unfortunately the error still remains.

    Here are some screenshots of the permissions:
    Click image for larger version

Name:	2009-07-22_163422.png
Views:	1
Size:	13.4 KB
ID:	468298
    Click image for larger version

Name:	2009-07-22_163512.png
Views:	1
Size:	15.1 KB
ID:	468299
    Click image for larger version

Name:	2009-07-22_165413.png
Views:	1
Size:	28.6 KB
ID:	468300
    Click image for larger version

Name:	2009-07-22_165626.png
Views:	1
Size:	31.5 KB
ID:	468301
    Click image for larger version

Name:	2009-07-22_165811.png
Views:	1
Size:	30.7 KB
ID:	468302
    I also had a screenshot for the Mailbox Store permissions but it's basically the same, the forum won't allow me to upload the 6th picture, so just imagine it


    Does anyone have a clue where I should look?

    Kind regards
    Robert

  • #2
    Re: [win2k3 + Exch 2k3] Exmerge Export problem

    http://support.microsoft.com/kb/262054

    The KB applies to 2003 aswell. Option 2 may be easier for you. The administrator account needs recieve as or full control as its denied by default.

    Alternatively you can use the migration wizard which is more robust than Exmerge and will allow you to preserve more of the details of the AD accounts as well as migrating them to .pst's. Its installed by default under deployment in Programs>MS Exchange.

    Comment


    • #3
      Re: [win2k3 + Exch 2k3] Exmerge Export problem

      Your best option is to use a special account for the export, rather than the administrator, due to the way that Administrator and Domain Admins are denied access to many things.

      I wrote about how to setup an account to do that here:
      http://www.amset.info/exchange/mailboxaccount.asp

      Simon.
      --
      Simon Butler
      Exchange MVP

      Blog: http://blog.sembee.co.uk/
      More Exchange Content: http://exchange.sembee.info/
      Exchange Resources List: http://exbpa.com/
      In the UK? Hire me: http://www.sembee.co.uk/

      Sembee is a registered trademark, used here with permission.

      Comment


      • #4
        Re: [win2k3 + Exch 2k3] Exmerge Export problem

        Hi guys

        Thanks for the answers, but as stated in my post I had removed all deny permissions and added full control to Administrator.

        Just in case I'm trying the suggestion from Sembee, but I'm getting stuck on #2 for the workstation setup.
        The link for the Exchange 2003 requirements [found here http://www.amset.info/exchange/tools-prereq.asp ] doesn't seem to work.
        All the rest is currently in place but I need to get those tools setup..
        Any tips?

        Tnx!

        Comment


        • #5
          Re: [win2k3 + Exch 2k3] Exmerge Export problem

          The page works now. I forgot to upload a component follow a data refresh of the site earlier in the year.

          Simon.
          --
          Simon Butler
          Exchange MVP

          Blog: http://blog.sembee.co.uk/
          More Exchange Content: http://exchange.sembee.info/
          Exchange Resources List: http://exbpa.com/
          In the UK? Hire me: http://www.sembee.co.uk/

          Sembee is a registered trademark, used here with permission.

          Comment


          • #6
            Re: [win2k3 + Exch 2k3] Exmerge Export problem

            Sorry for the late response, holidays and projects did that to me

            As for the exmerge issue, it's unfortunately still not resolved.
            I've followed all your steps, but now the error I'm getting is this:
            Click image for larger version

Name:	2009-08-03_142657.png
Views:	1
Size:	9.5 KB
ID:	464159

            When looking at the permissions everything seems to be ok as you've instructed, I've even restarted the Exchange System Attendant service, but no luck.

            AD User member of
            Click image for larger version

Name:	2009-08-03_142855.png
Views:	1
Size:	10.9 KB
ID:	464161
            Local Machine Administrators group
            Click image for larger version

Name:	2009-08-03_142940.png
Views:	1
Size:	7.2 KB
ID:	464160
            Exchange Delegate control
            Click image for larger version

Name:	2009-08-03_144545.png
Views:	1
Size:	9.1 KB
ID:	464162

            Any ideas?

            Comment


            • #7
              Re: [win2k3 + Exch 2k3] Exmerge Export problem

              *UPDATE*

              After being curious and browsing around I noticed the following details:
              While I had set my exmerge user through Delegation Control to be able to view the mailboxes, when I checked the server , storage group and mailbox store permissions, my user was nowhere to be seen.

              It seems that this company's previous system administrator has been tampering with the permissions to make them work for him, thus removing all the normal functionality.

              It seems that the server has NOT inherited permissions from the Exchange system environment, the storage group HAS inherited from the server and the mailbox store has NOT inherited from the storage group.

              Yet all the permissions are virtually identical.

              I'm thinking about setting all the permissions back to "inherit" from the Exchange system environment level down to the mailbox store, but do you know if this can cause serious harm?

              Kind regards
              Robert

              Comment


              • #8
                Re: [win2k3 + Exch 2k3] Exmerge Export problem

                The only harm that would come by resetting the inheritance would be some permissions that are current specifically set would stop working. You would need to ensure that they have been noted down so that you can reset them if required.

                Simon.
                --
                Simon Butler
                Exchange MVP

                Blog: http://blog.sembee.co.uk/
                More Exchange Content: http://exchange.sembee.info/
                Exchange Resources List: http://exbpa.com/
                In the UK? Hire me: http://www.sembee.co.uk/

                Sembee is a registered trademark, used here with permission.

                Comment


                • #9
                  Re: [win2k3 + Exch 2k3] Exmerge Export problem

                  thanks for the info.
                  I'm guessing that all my causes for exmerge still not working can be directly linked to that issue.

                  Unfortunately I won't be able to make those changes on exchange as it seems the server will be coming up for replacement within the next 6 months and I've been told I'll just have to make due with making .pst's through the Outlook client instead.

                  Anyone have any other options that allow me to make quick PST backups besides configuring this in Outlook and going through that whole process [during which it will first make a full local sync which is just a pain in the ass]?

                  Thanks for the help so far!

                  Comment

                  Working...
                  X