Announcement

Collapse
No announcement yet.

OWA http to https redirect not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OWA http to https redirect not working

    So I followed the article http://www.msexchange.org/tutorials/Securing-Exchange-Server-2003-Outlook-Web-Access-Chapter5.html to setup my http to https redirect, I was able to get the redirect to /exchange working, but for some reason the http to https redirect doesnt work. When I go to the page via http, I get no error, just that the page can no be displayed. I followed that article step by step and went back and forth over it any ideas?


    This is a Windows 2003 SBS Standard box with SP2 installed.
    Be easy on me, I'm here to learn

  • #2
    Re: OWA http to https redirect not working

    So I opened port 80 (duh on my part) but now I am getting the error You are not authorized to view this page
    Last edited by brcmadmin; 17th July 2009, 19:54.
    Be easy on me, I'm here to learn

    Comment


    • #3
      Re: OWA http to https redirect not working

      Open IIS browse to the virtual directory ( /exchange), right click>properties>directory security check the tab that says by default all PC's should be granted access. By the way with the SBS build the redirect is enabled by default under Isapi filters on the default website. The filter should already be there..
      Last edited by scurlaruntings; 17th July 2009, 20:07.

      Comment


      • #4
        Re: OWA http to https redirect not working

        Originally posted by scurlaruntings View Post
        Open IIS browse to the virtual directory ( /exchange), right click>properties>directory security check the tab that says by default all PC's should be granted access. By the way with the SBS build the redirect is enabled by default under Isapi filters on the default website. The filter should already be there..
        I already have that set there
        Be easy on me, I'm here to learn

        Comment


        • #5
          Re: OWA http to https redirect not working

          Are you accessing this from your LAN or from the internet? Try using HTTPS instead of HTTP and report back.

          Comment


          • #6
            Re: OWA http to https redirect not working

            WAN but I got it working, thanks!
            Be easy on me, I'm here to learn

            Comment


            • #7
              Re: OWA http to https redirect not working

              What did you do to dix it.

              Comment


              • #8
                Re: OWA http to https redirect not working

                I put this in the root


                <%

                If Request.ServerVariables("SERVER_PORT")=80 Then

                Dim strSecureURL

                strSecureURL = "https://"

                strSecureURL = strSecureURL & Request.ServerVariables("SERVER_NAME")

                strSecureURL = strSecureURL & "/exchange"

                Response.Redirect (strSecureURL)

                End If

                %>


                Named it owahttps.aspx, and set it as the first document in IIS on the default site
                Be easy on me, I'm here to learn

                Comment

                Working...
                X