No announcement yet.

Emails going AWAL

  • Filter
  • Time
  • Show
Clear All
new posts

  • Emails going AWAL

    Hi folks,
    I've run out of options on this one (Exchange 2003 SP2)
    A user, who happens to be the director of a company we deal with is having problems in that not all messages are appearing in his inbox.

    We had not been able to replicate the issue until today when I happened to send a test message from my phone (HTC/O2 XDA) using Outlook (activesync). I sent him a test and it did not appear in his inbox.

    His Active Directory account is set to forward a copy of all mail to an external address for his Blackberry. Mails that do not appear in his inbox do appear on his Blackberry so the messages are reaching the Exchange server and being processed.

    I have reset all the views on his PC, I have checked that there are no rules present in his Outlook (2007 - not in cached mode) and even used MFCmapi to check his profile and remove any hidden rules (there was 1, now there isn't).

    I've checked directly on the server with OWA, still no message.

    I also turned on message tracking on the Exchange server which threw more spanners in the works.

    One example message log is:

    This log indicates that the message was indeed delivered to his mailstore. Furthermore it shows up delivery to the blackberry servers. What is unexpected is the delivery to another completely unrelated user. There is nothing in his profile to tell the system to do this.

    With a bit of investigation it appears this unrelated user is some kind of message tracking user. It is getting copies of all the messages going through the Exchange system, but seems to purge them either at the end of the day or week. With a quick check, I can see that this is configured on the mailstore with "Archive all messages sent or received by mailboxes on this store".

    I don't think that this would cause the problems being experienced, but thought it worth mentioning.

    It is also worth mentioning that this is the same server where a portion of old calendar entries went AWAL from one user's account. We never got to the bottom of that. That is on this thread

    What do you think? I'm asking the client to leave his Outlook switched off tonight so I can send test messages and see if they appear in his inbox whilst Outlook is off. If they disappear when he loads Outlook I'll know its client side. Oddly enough, the email that I just sent to him from my office PC went through fine.

    The only spam filtering on the system is done via our mail server which is higher up in the chain and done before the message is handed off to the Exchange server. They are running Trend Worry Free Business Security Standard (No exchange filtering).

    I don't know what else to check. To the best of my knowledge there is nothing running that should remove messages - especially not silently!
    Last edited by beddo; 6th July 2009, 17:00.

  • #2
    Re: Emails going AWAL

    Update, it has now decided it likes me and my emails are all going through so I can't tell with more testing. I've turned on logging in Outlook to see if that throws up anything..


    • #3
      Re: Emails going AWAL

      If the message was delivered to the store according to message tracking, then the problem is almost certainly client side.

      To put it another way - I trust message tracking more than I trust the users.

      If the email is going somewhere else, then it must be a delegate, it could be a stuck delegate or a rule. Exchange does not send email to another user on its own.

      Simon Butler
      Exchange MVP

      More Exchange Content:
      Exchange Resources List:
      In the UK? Hire me:

      Sembee is a registered trademark, used here with permission.