Announcement

Collapse
No announcement yet.

OWA is not working when SSL is enable

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OWA is not working when SSL is enable

    i recently configured OWA with SSL which was working fined for about some months. i used microsoft CA as the certificate as directed at http://www.petri.com/configure_ssl_on_owa.htm. But for sometime now is not working. i have check various articles on the internet but to no avail. i have even uninstalled the certificate and reinstall it again but still is not working.

    http://ssmails.ssnit.org.gh is working that is if i disable SSL BUT
    https://ssmails.ssnit.org.gh is not.

    i downloaded trial certificate from verisign and EssentialSSL but still is not working, thinking the problem might be the microsoft CA. following http://www.msexchange.org/tutorials/...rtificate.html

    i have gone had to recreate the owa, exchange, exadmin.OMA as directed here
    http://www.petri.com/fixing_a_damage...stallation.htm

    i have also followed this article
    http://www.msexchange.org/tutorials/...-Chapter5.html.

    what should i do next

  • #2
    Re: OWA is not working when SSL is enable

    When you say it's not working, what do you mean? What happens? Have you allowed port 443 through your firewall?

    Comment


    • #3
      Re: OWA is not working when SSL is enable

      when i enable ssl at the IIS directory security, secure communication,edit and select required secure channel and require 128-bit encryption. then i restart IIS.
      then i type https://ssmails.ssnit.org.gh

      firefox displays the following
      The connection to ssmails.ssnit.org.gh was interrupted while the page was loading.

      and with explore it displays
      Internet Explorer cannot display the webpage

      Most likely causes:
      You are not connected to the Internet.
      The website is encountering problems.
      There might be a typing error in the address.

      What you can try:
      Check your Internet connection. Try visiting another website to make sure you are connected.
      Retype the address.
      Go back to the previous page.
      More information

      This problem can be caused by a variety of issues, including:

      Internet connectivity has been lost.
      The website is temporarily unavailable.
      The Domain Name Server (DNS) is not reachable.
      The Domain Name Server (DNS) does not have a listing for the website's domain.
      If this is an HTTPS (secure) address, click tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.

      For offline users

      You can still view subscribed feeds and some recently viewed webpages.
      To view subscribed feeds

      Click the Favorites Center button , click Feeds, and then click the feed you want to view.

      To view recently visited webpages (might not work on all pages)

      Click Tools , and then click Work Offline.
      Click the Favorites Center button , click History, and then click the page you want to view.

      port 443 is open on the firewall.

      Comment


      • #4
        Re: OWA is not working when SSL is enable

        when i enable ssl at the IIS directory security, secure communication,edit and select required secure channel and require 128-bit encryption. then i restart IIS.
        then i type https://ssmails.ssnit.org.gh

        firefox displays the following
        The connection to ssmails.ssnit.org.gh was interrupted while the page was loading.

        and with explore it displays
        Internet Explorer cannot display the webpage

        Most likely causes:
        You are not connected to the Internet.
        The website is encountering problems.
        There might be a typing error in the address.

        What you can try:
        Check your Internet connection. Try visiting another website to make sure you are connected.
        Retype the address.
        Go back to the previous page.
        More information

        This problem can be caused by a variety of issues, including:

        Internet connectivity has been lost.
        The website is temporarily unavailable.
        The Domain Name Server (DNS) is not reachable.
        The Domain Name Server (DNS) does not have a listing for the website's domain.
        If this is an HTTPS (secure) address, click tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.

        For offline users

        You can still view subscribed feeds and some recently viewed webpages.
        To view subscribed feeds

        Click the Favorites Center button , click Feeds, and then click the feed you want to view.

        To view recently visited webpages (might not work on all pages)

        Click Tools , and then click Work Offline.
        Click the Favorites Center button , click History, and then click the page you want to view.

        port 443 is open on the firewall.

        Comment


        • #5
          Re: OWA is not working when SSL is enable

          a) What happens if you access the owa using server Ip address from the local workstation i.e. https://<server-ip>/exchange. (I am assuming from local workstation it will bypass the firewall in your network)

          b) Is there any kind of redirection set on the Default Web Site?

          c) whats happens on server if you try to broswe owa on it with https?
          ________
          CSI: MIAMI ADVICE
          Last edited by Dks; 13th March 2011, 00:16.
          Rgds,

          Dks
          MCP E2K3 & MCITP E2K7
          MCITP Enterprise Win2k8

          Comment

          Working...
          X