No announcement yet.

Not able to receive mails

  • Filter
  • Time
  • Show
Clear All
new posts

  • Not able to receive mails


    I am having mail problem.

    Description: Not able to receive mails from any domain.

    Details: After replacing old ifrewall [ i.e. 515e PIX ] to Juniper SSG 140 UTM not able to receive mails.

    Details as follows:

    -I have Microsoft Exchange 2003 STD server [ stand alone ] integrated with AD
    -At gateway level have Cisco PIX 515e
    -Router is Cisco 1841
    -MX records etc is everything is in its place and my mail server is running since last 4~5 years so no issue with MX records, DNS [ public ] I beleive

    Problem: When I switch from PIX to SSG box I am able to send mails to any domains but not able to receive mails. I dont receive any failure notice if I send e-mail. It also passes from other mail server.
    -Problem looks kinda weird. We tried to allow all ports for public IP which is assigned to mail server.
    - After allowing ports tried to telnet at port 25 and it works.
    _ also tried to telnet at port 110 and it shows Microsoft Exchange version of my server.
    - But I can not receive mails in my Outlook.
    - At 1 point we thought it's a ARP problem so we did flushing , then restaring router and core switch inside LAN. But didnt help.
    - I checked public DNS in Exchange, in my internal DNS and at router & in SSG box they are in same order as existing.
    - All rest site-site vpn tunnels are up, anti spam, antivirus bundle is disabled.
    - We called Juniper but they are still not able to come with proper solution.
    - I wonder where is the problem?
    - Do I need to change any setting in Exchange 2003? I even tried restarting Remote and routing service in Exchange, restarted mailbox store and MTA stack.
    Didnt help.
    - When I switch back to PIX all mails I see in mailbox. This is strange.

    -There are 2 modes for NATing in Juniper we tried both. Bidirectional & uni directional. Didnt help too.

    Any clue's?

    Last edited by sco1984; 13th June 2009, 13:16.
    All in 1
    Solaris,Linux & Windows admin + networking.