Announcement

Collapse
No announcement yet.

Exchange SMTP log assistance

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange SMTP log assistance

    Hi,

    I was hoping someone could assist me with these smtp logs and advise where the fault is at, whether it has left my organization or not. The environment is kind of complex and is pretty new for me which makes it hard for me to pinpoint the issue as I'm still getting my head around it.
    The issue is that intermittently a user is having issues sending to the same address. Sometimes it goes through and others it doesn't. I'm not sure if anyone else is having these issues or if this certain user is having the same issues sending to other external addresses. Either way, I'm leaning towards email routing and\DNS or different email filters. I can confirm that both from email address and destination address are valid. Below are the smtp logs, the first is a successfull one sent to the same address and the 2nd one is the one which produced a delivery message. (Please note that I have amended the from and destination address and exchange server name for privacy reasons). Further information can be provided if required. Any assistance would be appreciated.


    Successfull SMTP log:

    116.50.58.190, OutboundConnectionResponse, 11/05/2009, 9:57:15, SMTPSVC1, Exchange Server, -, 1578, 0, 47, 0, 0, -, -, 220+cluster-m.mailcontrol.com+ESMTP+MailControl,
    116.50.58.190, OutboundConnectionCommand, 11/05/2009, 9:57:15, SMTPSVC1, Exchange-Server, -, 1578, 0, 4, 0, 0, EHLO, -, mail.domain.com,
    116.50.58.190, OutboundConnectionResponse, 11/05/2009, 9:57:15, SMTPSVC1, Exchange-Server, -, 2172, 0, 90, 0, 0, -, -, 250-cluster-m.mailcontrol.com+Hello+mail.domain.com+[59.154.53.129],+pleased+to+meet+you,
    116.50.58.190, OutboundConnectionCommand, 11/05/2009, 9:57:15, SMTPSVC1, Exchange-Server, -, 2187, 0, 4, 0, 0, MAIL, -, FROM:<[email protected]>+SIZE=4439,
    116.50.58.190, OutboundConnectionResponse, 11/05/2009, 9:57:15, SMTPSVC1, Exchange-Server, -, 2343, 0, 44, 0, 0, -, -, 250+2.1.0+<[email protected]>...+Sender+ok,
    116.50.58.190, OutboundConnectionCommand, 11/05/2009, 9:57:15, SMTPSVC1, Exchange-Server, -, 2343, 0, 4, 0, 0, RCPT, -, TO:[email protected],
    116.50.58.190, OutboundConnectionResponse, 11/05/2009, 9:57:15, SMTPSVC1, EXchange-Server, -, 2531, 0, 60, 0, 0, -, -, 250+2.1.5+<[email protected]>...+Recipient+ok,
    116.50.58.190, OutboundConnectionCommand, 11/05/2009, 9:57:15, SMTPSVC1, Exchange-Server, -, 2531, 0, 4, 0, 0, DATA, -, -,
    116.50.58.190, OutboundConnectionResponse, 11/05/2009, 9:57:16, SMTPSVC1, Exchange-Server, -, 2672, 0, 48, 0, 0, -, -, 354+Enter+mail,+end+with+"."+on+a+line+by+itself,
    116.50.58.190, OutboundConnectionResponse, 11/05/2009, 9:57:16, SMTPSVC1, Exchange-Server, -, 3468, 0, 54, 0, 0, -, -, 250+2.0.0+n4ANvD0p032227+Message+accepted+for+deli very,
    116.50.58.190, OutboundConnectionCommand, 11/05/2009, 9:57:16, SMTPSVC1, Exchange-Server, -, 3468, 0, 4, 0, 0, QUIT, -, -,
    116.50.58.190, OutboundConnectionResponse, 11/05/2009, 9:57:16, SMTPSVC1, Exchange-Server, -, 3625, 0, 55, 0, 0, -, -, 221+2.0.0+rly01m.srv.mailcontrol.com+closing+conne ction,


    Failed SMTP log:

    116.50.57.190, OutboundConnectionResponse, 11/05/2009, 7:28:07, SMTPSVC1, Exchange-Server, -, 1125, 0, 47, 0, 0, -, -, 220+cluster-k.mailcontrol.com+ESMTP+MailControl,
    116.50.57.190, OutboundConnectionCommand, 11/05/2009, 7:28:07, SMTPSVC1, Exchange-Serve, -, 1125, 0, 4, 0, 0, EHLO, -, mail.domain.com,
    116.50.57.190, OutboundConnectionResponse, 11/05/2009, 7:28:07, SMTPSVC1, Exchange-Server, -, 1250, 0, 90, 0, 0, -, -, 250-cluster-k.mailcontrol.com+Hello+mail.domain.com+[59.154.53.129],+pleased+to+meet+you,
    116.50.57.190, OutboundConnectionCommand, 11/05/2009, 7:28:07, SMTPSVC1, Exchange-Server, -, 1250, 0, 4, 0, 0, MAIL, -, FROM:<[email protected]>+SIZE=45144,
    116.50.57.190, OutboundConnectionResponse, 11/05/2009, 7:28:07, SMTPSVC1, Exchange-Server, -, 1625, 0, 44, 0, 0, -, -, 250+2.1.0+<[email protected]>...+Sender+ok,
    116.50.57.190, OutboundConnectionCommand, 11/05/2009, 7:28:07, SMTPSVC1, Exchange-Server, -, 1625, 0, 4, 0, 0, RCPT, -, TO:[email protected],
    116.50.57.190, OutboundConnectionResponse, 11/05/2009, 7:28:07, SMTPSVC1, Exchange-Server, -, 1750, 0, 60, 0, 0, -, -, 250+2.1.5+<[email protected]>...+Recipient+ok,
    116.50.57.190, OutboundConnectionCommand, 11/05/2009, 7:28:07, SMTPSVC1, Exchange-Server, -, 1750, 0, 4, 0, 0, DATA, -, -,
    116.50.57.190, OutboundConnectionResponse, 11/05/2009, 7:28:07, SMTPSVC1, Exchange-Server, -, 1875, 0, 48, 0, 0, -, -, 354+Enter+mail,+end+with+"."+on+a+line+by+itself,
    116.50.57.190, OutboundConnectionResponse, 11/05/2009, 7:28:11, SMTPSVC1, Exchange-Server, -, 4875, 0, 22, 0, 0, -, -, 550+5.1.1+User+unknown,
    116.50.57.190, OutboundConnectionCommand, 11/05/2009, 7:28:11, SMTPSVC1, Exchange-Server, -, 4891, 0, 4, 0, 0, QUIT, -, -,
    116.50.57.190, OutboundConnectionResponse, 11/05/2009, 7:28:11, SMTPSVC1, Exchange-Server, -, 5016, 0, 55, 0, 0, -, -, 221+2.0.0+rly03k.srv.mailcontrol.com+closing+conne ction,

  • #2
    Re: Exchange SMTP log assistance

    You can rule out routing and DNS as the cause of the problem with this particular transaction. The fact that your server connected to the remote server verifies that, in this case, routing and DNS were working correctly. If they weren't your server would not have made an SMTP connection to the remote server. The fact that the remote server responds with an SMTP 550 5.1.1 means that either:

    A. the server couldn't find the mailbox (after initially saying that the recipient was OK).

    B. The email in question was filtered by a spam filter or graylisted by the receiving server.

    In any event there's nothing you can do from your end to resolve this at the moment. You'll need to contact the recipient or the postmaster at the recipients company and ask them to track the message and tell you why it was blocked.

    Comment


    • #3
      Re: Exchange SMTP log assistance

      Also, whenever you have entries in the SMTP log you can most often rule out any DNS, routing, or connectivity problems as being the cause of the problem. DNS, routing, and connectivity all have to be working for the server to make an SMTP connection.

      Comment


      • #4
        Re: Exchange SMTP log assistance

        Thanks mate

        Comment

        Working...
        X