Announcement

Collapse
No announcement yet.

OWA not working externally

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OWA not working externally

    Hi All,

    I am having real problems. I have searched the site and see others had a similar issue - but could not see the fix.

    I can access OWA internally via http://servername/exchange. When I try to access it via http://ip/exchnage - it either just hangs after login pop up or if I use FF - it shows broken links.

    I have tried it in Basic too - and I also get the broken links. It seems to take forever to load anything too.

    I am use SB3 2003. SSL and FBA is off. Firewalls are off for testing purposes too,

    Any help would be appreciated,

  • #2
    Re: OWA not working externally

    Thats a routing issue. Have you got port 80 open and pointing to your server internally? Make sure you dont have any socket errors (ie web management enabled on the router on port 80 as well). In addition do make sure you use the correct syntax /Exchange preceeded by the correct A record.

    Comment


    • #3
      Re: OWA not working externally

      Port 80 is open - in fact all Firewalls are open during the debug period - so I know its not that.

      It will ask for login credentials - and start to load - but then just hnags there - so I feel I am getting to the right port etc,

      As for the address (syntax) - I know it to be correct it "was" working before. If I create a VPN or stay on the LAN works perfectly.

      However - if you have some suggestions to try to rule this out - I am all ears....

      Comment


      • #4
        Re: OWA not working externally

        What have you changed (since you say "was working before)?
        Since its SBS, have you re-run the CIEW wizard?
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Re: OWA not working externally

          What did I change......That is an intersting story.

          I had the red x problem with OWA - after several failed attempts to get it working - resetting Virtual Directorys etc - it was working with FBA - with a reg fix to avoid it having to use SSL.

          Then I realised that you cant use OMA or Activesync with SSL/FBA enabled. I followed some notes on creating a second virtual directory - and the whole lot stopped working.

          I went back to the beginning, removed the "fixes" for FBA over a non SSL" and the red x problem came back. I then recreated the Virtual Directories - checked the required OWA settings and I am where I am now.

          As a last point - if I use Basic it will load with broken links, no send buttons etc - externally that is - premium works 100% normal on the LAN/VPN.

          PS - Everytime I run Email and Internet Connection wizard it says "to send mail server cannot be a bridgehead server"
          Last edited by Scotty501; 26th May 2009, 13:24.

          Comment


          • #6
            Re: OWA not working externally

            Try changing your router.
            Joined: 23rd December 2003
            Departed: 23rd December 2015

            Comment


            • #7
              Re: OWA not working externally

              Thanks for yeplay Biggles - but i dont think it is hardware related.

              It was working for a few days last week until I tried created a second Virtual Directory to avoid the SSL/FBA and OMA issues. So I know it CAN work - just not sure what option I have not ticked or enabled....

              Comment


              • #8
                Re: OWA not working externally

                OK I have managed to get it working through FBA on external http://xx.xxx.xx.xxx/exchange and through https://xx.xxx.xx.xxx/exchange.

                Which is where I got to before. I have done this without a certificate through a reg edit.

                However, this is where I go wrong - as this knocks out OMA and Activesync. So what do I need to do?

                Comment


                • #9
                  Re: OWA not working externally

                  Sounds to me like you've broken SBS. If i were you id run a repair installation and restore it to its original configuration.

                  Comment


                  • #10
                    Re: OWA not working externally

                    I dont agree its broken - what makes you say that?

                    The problem is with the OMA & Active Synce not being able to access Exchange if FBA or SSL is enabled. You should create a second Virtual Directory - but this is the bit I dont know how to do - it should be simple apart from the last part which you are supposed to run the Email and Internet Wizard - which I cant do as I get a message saying "mail server cannot be a bridgehead server"

                    Comment


                    • #11
                      Re: OWA not working externally

                      Hi,

                      Do one basic test i.e. try browsing the owa with IP (http://ip/exchnage) on the exchange server itself and let me know how it behaves for this test.

                      Can you let us know which article you have followed and till what point for OMA & Active Synce not being able to access Exchange if FBA or SSL is enabled
                      ________
                      Sauber F1.09
                      Last edited by Dks; 13th March 2011, 00:12.
                      Rgds,

                      Dks
                      MCP E2K3 & MCITP E2K7
                      MCITP Enterprise Win2k8

                      Comment


                      • #12
                        Re: OWA not working externally

                        Thanks for the reply DKS.

                        If I use http://ip/exchange - it loads perfectly. On client machines or external - I get some links but not others or it just hangs there...unless i access it on the LAN vis http://servername/exhange

                        If I access it via the LAN or VPN works beautifully.

                        When I enable FBA it works beautifully externally and internally via http://ip/exchange - and via SSL - albeit with a certificate problem - which I can fix later.

                        The problem with FBA is that it wont allow Activesynce/OMA access. The work around does not seem to do the trick - MS Article :- http://support.microsoft.com/Default.aspx?kbid=817379

                        One issue maybe I cannot run CEICW as it wont run on a bridghead server after being run once at the setup many moons ago. So close to fixing this - yet can quite find the last box to check.

                        Comment

                        Working...
                        X