No announcement yet.

OWA not opening with Public IP

  • Filter
  • Time
  • Show
Clear All
new posts

  • OWA not opening with Public IP

    Hello All,

    Setup: Windows 2003, Exchange 2003, ISA 2006.

    I have published OWA using commercial certificate, its opening fine with the FQDN. however if i try to open this using public ISA ip address its giving certificate error. Kinldy suggest if any problem related to ISA rules.

    the possible solution from my point view is that we need to forward all traffic using IP address to FQDN as this is the case with gmail when we try to open with ip address it immediated redirects all traffic to gmail fqdn.


  • #2
    Re: OWA not opening with Public IP

    If I'm understanding what you're saying then that is the expected behavior. The certificate is for the FQDN (or alias or whatever you chose to name it) of the server, such as: When you connect via the ip address you get the certificate error because you're connecting to https://x.x.x.x and the certificate is for https://fqdn. Your browser is telling you that the address you typed doesn't match the certificate which is correct, it doesn't.


    • #3
      Re: OWA not opening with Public IP

      First of all thanks for the reply,

      Yes you are right. now two question....

      Q-1 Is there any way to solve this issue or i need to continue with the FQDN.

      Q-2 When we try to open gmail with ip address it immediately redirect us to URL. is this from ISP end or we need to do some settings throug IIS.

      Thanks a lot!


      • #4
        Re: OWA not opening with Public IP

        Q-1: It's not an issue. this is the expected behavior. If the address you type in your browser (ip address or FQDN) doesn't match the"friendly name", or "common name" of the certificate you will get the certificate error. This is the way SSL works. If it didn't warn you about an invalid certificate (because you typed a different FQDN or used the ip address) then SSL wouldn't be a very good security mechanism.

        Q-2: I'm not sure what gmail has to do with your IIS and OWA. I suspect gmail does a redirect with their firewall or web server when you type the ip address. I suppose you could do the same thing with your IIS and OWA by redirecting the default web site to your Exchange virtual directory.


        • #5
          Re: OWA not opening with Public IP

          Thanks, i'll see in IIS and let you know.