Announcement

Collapse
No announcement yet.

Cannot access Exchanger server from internet via Outlook

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot access Exchanger server from internet via Outlook

    I am running an Exchange 2003 SP2 server on Windows 2003 Server on a dedicated machine with a Blackberry Professional Server 4.1.4. It is a personal server to be used as family members' mail server. The internet connection is a COMCAST cable connection with a dynamic IP managed through changeip.com (so if the IP changes, the DNS addresses automatically get changed). The cable modem is attached to a Netgear Wireless Router that automatically forwards all the incoming ports to the Windows/Exchange Server that has a fixed intranet IP 192.168.10.50. The server's machine name is SERVER. There is a chnageip.com regisration for server.mydomain.com and www.mydomain.com. After all this background information, let me tell what my problem is:

    I can set up outlook 2003 or 2007 on my computers and laptops to access the exchange server. There is no problem as long as I am using the wireless network that I've set up (the intranet). Whenever I leave my house and use my laptop via a free WIFI or AT&T 3G Network, and launch outlook, the program gives an error message saying it cannot access the exchange server. I can access my Exchnage Server through internet explorer using https://www.mydomain.com/exchange or https://server.mydomain.com/exchange. I can even access the server via WM 6.1 Activesync. I changed outlook settings to try to access via HTTP, increased the timeout setting. No luck. I have all the ports forwarded to the server.

    Any troubleshooting ideas?
    Last edited by onurd; 7th May 2009, 04:15.

  • #2
    Re: Cannot access Exchanger server from internet via Outlook

    Do you have Outlook configured to connect via RPC over HTTP? Do you have the RPC proxy component installed on the Exchange server? This page has a link to the RPC over HTTP deployment guide:

    http://support.microsoft.com/kb/833401

    Comment


    • #3
      Re: Cannot access Exchanger server from internet via Outlook

      Hmmm... Looking at this, I don't think I have the RPC server configured. What I don't understand is, how the Activesync works and OUTLOOK doesn't work (even if I don't have RPC server). One more thing: so the only way to access an exchange server without RPC is a VPN server?

      Comment


      • #4
        Re: Cannot access Exchanger server from internet via Outlook

        Because Outlook makes direct TCP/IP calls to the Active Directory Directory Service, and to the Exchange server, on specific TCP/IP ports. I highly doubt you have opened those ports in your firewall, and strongly recommend that you don't.


        THe reason ActiveSync works is because it makes it's calls to Exchange over the Web server on port 80 or (hopefully) port 443.
        You can replicate this by using RPC over HTTP (also called Outlook Anywhere) and yes, the only other way to access an exchange without using RPC is to use a VPN connection.


        Why don't you want to use RPCoHTTP ?
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment


        • #5
          Re: Cannot access Exchanger server from internet via Outlook

          I tried to activate RPC and still no luck. Here is what I did step by step:

          1) Installed RPC over HTTP Proxy from Start-->Control Panel-->Add/Remove Programs-->Windows Components-->Networking Services-->RPC over HTTP proxy.

          2) In Exchange System Manager-->Servers-->SERVER-->properties-->RPC-HTTP checked RPC-HTTP back-end server

          3) In IIS Manager-->SERVER-->Web Sites-->mydomain.com-->RPC-->Properties, chose Directory Security, then under Authentication and access control, cleared Enable anonymous access, then only selected Basic authentication, with mydomain.com in the Deafult Domain box. Then chose Secure Communications again under RPC-->Properties-->Edit, checked Require secure channel (SSL) and Require 128-bit encryption and Ignore Client Certificates.

          4) Made sure following registry keys exist:

          HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\MSExchangeIS\ParametersSystem
          Value name: Rpc/HTTP Port
          Value type: REG_DWORD
          Value data: 0x1771 (Decimal 6001)
          HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\MSExchangeSA\Parameters
          Value name: HTTP Port
          Value type: REG_DWORD
          Value data: 0x1772 (Decimal 6002)
          HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\MSExchangeSA\Parameters
          Value name: Rpc/HTTP NSPI Port
          Value type: REG_DWORD
          Value data: 0x1774 (Decimal 6004)


          5) Started regedit, went to HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\RpcProxy , modified the ValidPorts subkey to

          Server:6001-6002;server.mydomain.com:6001-6002;server:6004;server.mydomain.com:6004;



          6) Modified the outlook profile that was working in the intranet with Exchange Proxy settings.

          Still no luck.

          Any ideas?

          Comment


          • #6
            Re: Cannot access Exchanger server from internet via Outlook

            Do you have an SSL certificate in place? If not then you need to.
            If you do, is a commercial certificate? Again if not then I would suggest that you do. GoDaddy do SSL certificates for US$30/year, which are fine for this feature, ActiveSync and OWA as well. https://CertificatesForExchange.com/

            Test the configuration using a test account and the Microsoft test site:
            https://testexchangeconnectivity.com/

            See what that flags.

            Simon.
            --
            Simon Butler
            Exchange MVP

            Blog: http://blog.sembee.co.uk/
            More Exchange Content: http://exchange.sembee.info/
            Exchange Resources List: http://exbpa.com/
            In the UK? Hire me: http://www.sembee.co.uk/

            Sembee is a registered trademark, used here with permission.

            Comment


            • #7
              Re: Cannot access Exchanger server from internet via Outlook

              I finally got it to work, the only difference is was that I had to change the ports since my servers internal name (SERVER) was different than the regular DNS registry (WWW or MAIL). So once I changed the registry entry to reflect both the mail.mydomain.com and server.mydomain.com with the ports 6001, 6002-6004, it started working. However the Outlook asks my password everytime even if I check "save my password". Is there any way to change this?

              Comment


              • #8
                Re: Cannot access Exchanger server from internet via Outlook

                Originally posted by onurd View Post
                I finally got it to work, the only difference is was that I had to change the ports since my servers internal name (SERVER) was different than the regular DNS registry (WWW or MAIL). So once I changed the registry entry to reflect both the mail.mydomain.com and server.mydomain.com with the ports 6001, 6002-6004, it started working. However the Outlook asks my password everytime even if I check "save my password". Is there any way to change this?
                yep. you need to use a certificate, and the MSSTD: part in the OA configuration.. ?i can't remembre it exactly off the top of my head
                Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

                Comment

                Working...
                X