Please Read: Significant Update Planned, Migrating Forum Software This Month

See more
See less

First OMA Setup.

  • Filter
  • Time
  • Show
Clear All
new posts

  • First OMA Setup.


    I'm attempting to setup an iPhone on my Exchange 2003 SP2 server for the first time. There's no frontend server for my setup.

    I followed the instructions in the KB at

    However, whenever I attempt to access via normal browser at I get an error. The even log is below.

    I suppose the only thing that I had a question on when following the instructions was putting the IP of the server in the deny area. But I've tried with both the public and private IP of the server to no avail.

    If someone could point me in the right direction it would be much apprecated.


    An unknown error occurred while processing the current request:
    Message: The remote server returned an error: (403) Forbidden.
    Source: Microsoft.Exchange.OMA.ExchangeDataProvider
    Stack trace:
    at Microsoft.Exchange.OMA.ExchangeDataProvider.OmaWeb Request.GetRequestStream()
    at Microsoft.Exchange.OMA.ExchangeDataProvider.Exchan geServices.GetSpecialFolders()
    at Microsoft.Exchange.OMA.ExchangeDataProvider.Exchan geServices..ctor(UserInfo user)

    Message: Exception has been thrown by the target of an invocation.
    Source: mscorlib
    Stack trace:
    at System.Reflection.RuntimeConstructorInfo.InternalI nvoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean isBinderDefault)
    at System.Reflection.RuntimeConstructorInfo.Invoke(Bi ndingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
    at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
    at Microsoft.Exchange.OMA.UserInterface.Global.Sessio n_Start(Object sender, EventArgs e)

    Message: Exception of type Microsoft.Exchange.OMA.DataProviderInterface.Provi derException was thrown.
    UserMessage: A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.
    Source: Microsoft.Exchange.OMA.UserInterface
    Stack trace:
    at Microsoft.Exchange.OMA.UserInterface.Global.Sessio n_Start(Object sender, EventArgs e)
    at System.Web.SessionState.SessionStateModule.RaiseOn Start(EventArgs e)
    at System.Web.SessionState.SessionStateModule.Complet eAcquireState()
    at System.Web.SessionState.SessionStateModule.BeginAc quireState(Object source, EventArgs e, AsyncCallback cb, Object extraData)
    at System.Web.AsyncEventExecutionStep.System.Web.Http Application+IExecutionStep.Execute()
    at System.Web.HttpApplication.ExecuteStep(IExecutionS tep step, Boolean& completedSynchronously)

    For more information, see Help and Support Center at

  • #2
    Re: First OMA Setup.

    Issue fixed. Apperantly I had forgotten to reset IISAdmin along the way..


    • #3
      Re: First OMA Setup.

      Hello Guy's

      Good question
      As you need to configure Exchange ActiveSync so we need to follow kb 817379 only if we have a single server and we have SSL force on Exchange or FBA enabled

      Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003

      We need to first uncheck SSL from Exchange virtual directories and FBA from Exchnage System Manger if present
      Make sure that Exchange virtual directory should have Basic + intergarted authentication in IIS manager

      Then follow Kb 817379 and don't apply IP address restiction on OMA or any directory.
      As we are using Exchange ActiveSync so OMA don't come in picture as
      OMA is old technology

      try and browse Microsoft-Server-ActiveSync and we should get 501/505
      it may prompt you for user name and password

      I belive this should resolve you issue.


      Gurmeet Kohli