Announcement

Collapse
No announcement yet.

Public Folders / SSL error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Public Folders / SSL error

    I'm recently run into an issue with out Exchange 2000 Enterprise server where connecting to it's public folders via Exchange System Manager (ESM) is throwing out this error:
    Code:
    The token supplied to the function is invalid.
    ID no: 80090308
    Exchange System Manager
    This MS article suggest this is an SSL issue and to do one of the following:
    1. Remove the SSL cert and replace with one using the FQDN of the server
    2. Remove SSL from the Exadmin virtual root in IIS

    Unfortunately the server is mail1.domain.local internally and the cert is for office.domain.com externally so option #1 isn't really an option as far as I understand it.

    I've run through option #2 but there was no change.

    I've also tried using ADSIedit to tweak the msExchSecureBindings settings by removing the 443 port requirement as per here but the option had not been set already.

    Any suggestions would be greatly appreciated at this point as I'm down to head scratching and guessing now.

    server: Windows 2000 Server STD running Exchange 2000 Ent
    others: All other Exchange boxes are 2003 server and Exchange.
    This message represents the official view of the voices in my head

  • #2
    Re: Public Folders / SSL error

    After making the change, did you run IIS reset or restart the IIS services for the change to take effect?

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Public Folders / SSL error

      I sure did.

      The exchange services have been restarted since too but no change. Officially head scratching now to be honest
      This message represents the official view of the voices in my head

      Comment


      • #4
        Re: Public Folders / SSL error

        In that case I would have to presume the folder configuration is corrupt.

        Recreate them. http://support.microsoft.com/default.aspx?kbid=883380

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: Public Folders / SSL error

          Just thought I'd report back on this one as we finally resolved it.

          The cause turned out to be a tick box for "use 128 bit encryption" being enable under one of the menus even though "use ssl" was turned off.
          Enabled ssl, removed tick from use 128 bit, disabled ssl again and all's happy.

          strange that it was causing an issue even though it was disabled but you live and learn.

          Cheers for the help on this one, folks.
          This message represents the official view of the voices in my head

          Comment

          Working...
          X