No announcement yet.

Exchange 2003 OWA "loading" issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange 2003 OWA "loading" issue


    Running W2003 server SP2 w/Exchange 2003 SP2 on a single
    server (No FE/BE)

    Running OWA w/SSL and valid cert.

    Getting that classic "loading" screen in OWA after entering my

    Have not made any recent changes prior to this happening,
    just started one morning out of the blue.

    This happens whether I am inside or Outside the local LAN

    What I have tried so far....

    Deleted and re-created the IIS virtual directories.
    verified all permissions
    disabled SSL on OWA just to see if it made a didnt.
    Finally removed IIS completely, reinstalled IIS and did a
    reinstall of Exchange. Nothing.

    I'm lost here.

    Any help would be very much appriciated.. next step might
    be a support call with MS.



  • #2
    Re: Exchange 2003 OWA "loading" issue

    I had this before a long time ago but applying Exchange SP1 fixed it though I see you are already on SP2 - did you check the SP even after the reinstall? Otherwise I wonder if this helps:

    Outlook Web Access stuck at Loading...

    In that conversation, running the follwing two lines fixed it for him:

    regsvr32 C:\systemfolder\System32\msxml3.dll
    regsvr32 C:\systemfolder\System32\msxml.dll"
    Best wishes,
    MCP:Server 2003; MCITP:Server 2008; MCTS: SBS2008


    • #3
      Re: Exchange 2003 OWA "loading" issue

      Hi Paul,

      Thanks for the response. I did re-register those 2 dll's and re-applied
      SP2 after I did the Exchange reinstall.

      Thanks for the suggestions though. This thing has been a
      major pain. I think I need a right about now.


      • #4
        Re: Exchange 2003 OWA "loading" issue

        how did you delete and recreate the vdirs, using ds2mb or manually ?

        Do you get loading... on /public as well?


        • #5
          Re: Exchange 2003 OWA "loading" issue

          Well it seems I found the solution...

          Having exhausted everyting I know of, short of wiping
          out the server and reinstalling everything, I started
          thinking mime types. Since that controls what IIS loads
          in a web page I decided to check mine.

          So I went in IIS manager, right clicked my server >properties
          and clicked on the Mime types button and it hit me right away.

          There were only 7 mime types listed. There should be at least
          a few dozen in there. How they got wiped out I have no idea.

          So I added a new mime type with an extension of *,
          with a mime type of application/octet-stream,
          ran iisreset and OWA worked

          Adding a mime type with an extension of * tells IIS basically
          to load any ext.

          So now is there a way to reset all the mime types to just the defaults needed?

          Thansk everyone for your help.