No announcement yet.


  • Filter
  • Time
  • Show
Clear All
new posts

  • SSL & OWA

    Hi there,

    I've got a small problem.

    My Exchange keeps asking me to connect to the owa through SSL

    How can i disable the use of https:// ??

    Or make it so that if i type:
    http://localhost/exchange it will redirect me to the https address?

    Any help on this matter would be very apriciated.

    Thank you for reading and kind regards,

    Jorge Valencia

  • #2
    In the proerties of the default site (in IIS manager), goto Directory Security, then click Edit under Secure Communications.

    Untick require secure channel.

    But if this is available on the internet I would highly recommend against this.

    If you want an automatic redirect, create an asp page (with code below) and set as default document.

    <% response.redirect ("https://exchangeserver/exchange")%>
    * Shamelessly mentioning "Don't forget to add reputation!"


    • #3
      Hi Topper

      As a new thread- Which page would you place the new default.asp into? Exchange, Exchweb, or the main default page?

      I have tried all 3 but cannot get it to work?



      • #4
        Somebody shoot me if I have misunderstood the question, but I created (copied) the below code and popped it into Owahttps.asp and that resides in \\mail\c$\Inetpub\wwwroot\OWAasp\Owahttps.asp .

             If Request.ServerVariables("SERVER_PORT")=80 Then
                 Dim strSecureURL
                 strSecureURL = "https://"
                 strSecureURL = strSecureURL & Request.ServerVariables("SERVER_NAME")
                 strSecureURL = strSecureURL & "/exchange"
                 Response.Redirect strSecureURL
             End If
        The following shows you how to make it easier for L User to log onto OWA. It removes the need to add the NetBIOS domain name in the logon window. Hope this is of some help.;x=10&y=16
        Joined: 23rd December 2003
        Departed: 23rd December 2015


        • #5
          I have something similar but have not gotten it to work. From the outside:

          https:\\\exchange works but I would like

          https:\\ to work and then eventually (after setting up certs just:

          I have inserted an asp page called index.asp which only has
          <% Response.Redirect "" %>

          If I put the page into the Default website in IIS and add it to the documents section I can get it to come up in a browser but it was supposed to redirect to /exchange and bring up the OWA log in.

          OK, so I am a big time rookie at webpages


          • #6
            That should work, just dump Index.asp into you root (usually c:\inetpub\wwroot), and ensure Index.asp is the first page to get hit in your default documents list.

            * Shamelessly mentioning "Don't forget to add reputation!"


            • #7
              Sorry for jumping in late, but why not just create a virtual directory. for example http://server/mail which will forward to https://server/exchange ?

              Daniel Petri
              Microsoft Most Valuable Professional - Active Directory Directory Services
              MCSA/E, MCTS, MCITP, MCT


              • #8
                Here was my problem, I was thinking too much- I actually created a webiste using frontpage and named it index.asp. I didn't realize that all I needed to do was to open notepad and insert the command redirect and then save the doc as an .asp file.

                Then just install it into the wwwroot and make it the 1st page of the Exchange website.

                " Stupid networking guys- They should just stay out of servers and programming! "