No announcement yet.

Test restore - eseutil reporting dirty shutdown

  • Filter
  • Time
  • Show
Clear All
new posts

  • Test restore - eseutil reporting dirty shutdown

    I'm new, but have been reading this site for hello everyone!

    I've been doing some DR testing and am having a problem restoring one of my Exchange 2003 databases. I have two databases and storage groups on my server. I can restore the main one (first storage group) successfully, but not the second one. The main one is also much much larger than my second one, which is a mere 4GB.

    Using NT backup I run a normal backup of the second storage group and its database. I bring it into my test exchange server and use NT backup to restore. I've tried selecting "this is the last backup set" or whatever the setting is, but it doesn't make a difference.

    eseutil /cc does not complete because the database is in a "dirty shutdown" state

    What I'm having a hard time understanding is WHY this database is being tagged as "dirty shutdown" when it's being restored from a backup. The database in the production environment is working without any problems, and is consistent. If it's a problem with the load on the server, it makes no sense because that store has 50 people or so, whereas my main store has 800+ mailboxes with heavy users and I can restore that a-okay (very grateful for that!!!). I also can't run eseutil /r on the recovered database because it complains log files are missing...don't know what it's looking for specifically. Signatures on the edb and stm files are identical. eseutil /p works to repair the DB and it can be mounted after the fact, but that's not something I want to do in a DR situation as I can risk loosing uncommited data.

    I've tried with many different backup sets from the past six months, and they all have the same result. The exchange server has been rebooted between different backup sets, and there have no been any unexpected power outages in over a year. NT backup is purging the transaction logs like it should be... Perhaps on the weekend I'll schedule some time to do an offline copy of the DB and also run eseutil /mh and see what it reports....but that doesn't fix my backup problem

    Any ideas why this might be happening?

  • #2
    Re: Test restore - eseutil reporting dirty shutdown

    Have you considered that the database itself might have a problem?
    Certainly if another database works correctly on the same restore process then it would indicate the source might be suspect.

    If you have multiple databases you must be on Enterprise edition. Therefore I would be looking to create a new database and move the content to it.

    Simon Butler
    Exchange MVP

    More Exchange Content:
    Exchange Resources List:
    In the UK? Hire me:

    Sembee is a registered trademark, used here with permission.


    • #3
      Re: Test restore - eseutil reporting dirty shutdown

      "What I'm having a hard time understanding is WHY this database is being tagged as "dirty shutdown" when it's being restored from a backup. "

      All online backups are "dirty" as the db is online at the time the backup is created. Selecting "this is the last backup set" and or running eseutil /cc will bring them to a clean state as long as you have the required log files.

      run eseutil /mh on the db's and look for "logs required".
      Do you have these logs ?

      If not, sorry but your SOL and you will need to /p.
      If you do, then you should be able to get to a clean state and roll logs forward to the point of failure.