Announcement

Collapse
No announcement yet.

Issue with `Send as`

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue with `Send as`

    Hi, Iam having a weird permissions issues.

    I had to deleted and recreate a mailbox and move all the emails back to the mailbox due to a database problem.

    The mailbox is working fine but authorised people are unable to send AS this mailbox. They are getting this error message: You dont have permissions to send on behalf of this user.

    The users,, are added in Send on behalf and also they are ``send as`` enabled in the security tab of the mailbox in AD.

    I tried to delete the exchange attributed of the mailbox, reconnect it and regive the rights to the user.. same problem. I also restarted the information store and i got the same problem

    Any ideas?!

  • #2
    Re: Issue with `Send as`

    Are these users members of any groups that are explicitly denied any rights (especially send as)?

    Do the users have full mailbox access and read access in the mailbox?

    Did you give it 10 mins or so after applying the permissions before you tested it? Restart the Outlook client?

    Also, please explain what sort of "database" problems you were having. Corrupted items in a database can cause all sorts of strange problems!! Also ensure that your AD and DNS are functioning properly as that can affect permissions.

    Comment


    • #3
      Re: Issue with `Send as`

      Are these users members of any groups that are explicitly denied any rights (especially send as)? I checked that already but I just removed intehrited rights to make sure.


      Do the users have full mailbox access and read access in the mailbox?Yes they do

      Did you give it 10 mins or so after applying the permissions before you tested it? Restart the Outlook client? Yes.. I also did a full restart on computers and I restared the information Store in Exchange

      Also, please explain what sort of "database" problems you were having. Corrupted items in a database can cause all sorts of strange problems!! Also ensure that your AD and DNS are functioning properly as that can affect permissions.

      I had a mailboxstore database that got totally corrupted because the last admin at my work let the disk go full ..... I moved the other mailboxes to the other server.. and i had to remove the mailboxtroe and recreate that mailbox manually and recreate the rights on the mailbox

      Thanks for the help

      Comment


      • #4
        Re: Issue with `Send as`

        Don't set both Send As and Send on Behalf of. They are different and it should be one or the other set. If you have to change it then you will need to either wait the two hours for the permission change to take effect or restart the information store.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: Issue with `Send as`

          Thank you,

          I will try that.
          I just restarted the Information store.
          I will wait for the users to come in and I will let you know.

          Comment


          • #6
            Re: Issue with `Send as`

            Thank you,

            I am pretty sure that it worked.
            I did not hear anything back from the users.

            Comment

            Working...
            X