Announcement

Collapse
No announcement yet.

Exchange syncs with WM device but no emails appear

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange syncs with WM device but no emails appear

    Hi

    This is my first post so please be kind

    i am currently running a SBS 2003. I seem to be having problems with syncing my windows mobile phones, one WM5 and the other WM6. I installed a 3d party certificate which works fine. i have even created the exchange-oma virtual directory in IIS as i do not have a back-end exchange. OWA works fine as i can access OWA internally and externally with SSL.

    The problem I am having is that when I enter the account details on the WM device, the email settings are correct as the enforced password policy gets enabled and the sync process goes through without any error messages. It shows a message that I have 5/5 emails in my inbox but never downloads them onto the WM device. This is the same for contacts and tasks. I can however send emails from the WM device to other recipients who receive the emails fine.

    How do I get emails downloaded onto my windows mobile,Please can anyone help? i`m on my last strand of hair

  • #2
    Re: Exchange syncs with WM device but no emails appear

    Is this SBS 2003 or SBS 2003 R2?
    If it was R2 then you should already have the exchange-oma virtual directory configured.
    Have you run the Connect to the Internet and Email wizard to ensure that the feature is enabled?

    Have you tested the Windows Mobile emulator to confirm it isn't the device? Links are in the sticky at the top of the thread.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Exchange syncs with WM device but no emails appear

      Hi

      the server is SBS 2003 RC2, i have run the internet and email wizard which does not help, and no the mobiles are working fine as they work with another exchange which belongs to my office. on the other exchange the mobiles sync and download emails fine.

      Comment


      • #4
        Re: Exchange syncs with WM device but no emails appear

        If you are using SBS 2003 R2 then you shouldn't have needed to setup the exchange-oma virtual directory, it is done for you. That would tend to indicate that all is not well with the setup.

        If you have tried devices attached to other servers, did you hard reset them before trying them with another machine?

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: Exchange syncs with WM device but no emails appear

          Yes your right the exchange-oma vitual directory was there, however i tried to recreate the virtual folder again as i was experiencing the problems indicated before were the windows mobile device would sync with the exchange and indicate that i have so many emails in my inbox but never downloads them onto the WM device. and yes i did hard reset the WM devices.

          Comment


          • #6
            Re: Exchange syncs with WM device but no emails appear

            Originally posted by ryker View Post
            Yes your right the exchange-oma vitual directory was there, however i tried to recreate the virtual folder again as i was experiencing the problems indicated before were the windows mobile device would sync with the exchange and indicate that i have so many emails in my inbox but never downloads them onto the WM device. and yes i did hard reset the WM devices.
            That was your problem.
            The instructions in 817379 are flawed. They presume that the require SSL option is not set on the /exchange virtual directory. However in SBS it will be. The problem is then brought across.

            I presume you mean you were getting the error code 8400014? There are other causes of that error (which means cannot authenticate) of which the issue in 817379 is the most common.

            I would suggest that you remove the virtual directory that you created, and the registry key. Then run iisreset in a command prompt to write the changes to the iis metabase. Then run the wizard again to configure the server as SBS wants it configured.

            After completing the wizard, see if the virtual directory was created. It should be.
            Then test the feature internally. If you don't have a Windows Mobile device on your network then use the emulator - links in the sticky thread at the top.

            Simon.
            --
            Simon Butler
            Exchange MVP

            Blog: http://blog.sembee.co.uk/
            More Exchange Content: http://exchange.sembee.info/
            Exchange Resources List: http://exbpa.com/
            In the UK? Hire me: http://www.sembee.co.uk/

            Sembee is a registered trademark, used here with permission.

            Comment


            • #7
              Re: Exchange syncs with WM device but no emails appear

              i not sure what you want me to do here.

              Comment


              • #8
                Re: Exchange syncs with WM device but no emails appear

                Originally posted by ryker View Post
                i not sure what you want me to do here.
                I said what to do above.
                If you don't want to do that then call Microsoft and pay their fee.

                Simon.
                --
                Simon Butler
                Exchange MVP

                Blog: http://blog.sembee.co.uk/
                More Exchange Content: http://exchange.sembee.info/
                Exchange Resources List: http://exbpa.com/
                In the UK? Hire me: http://www.sembee.co.uk/

                Sembee is a registered trademark, used here with permission.

                Comment

                Working...
                X