No announcement yet.

Exchange and SQLMail.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange and SQLMail.

    Hi Guys,

    This might be a SQL issue but I doubt it, (plus there isn't a DB forum!!).

    7 managed SQL servers (2000 Ent), Srv and Agent running under same account (below).
    1x SQLSRV Account (Domain Account), mail enabled.
    1x Exchange 2003 Cluster.
    1x AD 2000 Domain.

    6 SQL servers constantly running, SQL Mail not an issue. Outlook will open (when logged on as SQLSRV) no problems.

    1 Server (SQL3), outlook will not open, comes up with

    "Unable to open your default email folder, attempt to logon to your exchange server has failed"

    Now the strange part, if I stop the SQL Agent on any of the other SQL servers, I can then open outlook and SQLMail works fine, and will continue to work fine until one of the other SQL Agents is started again.

    To me, it looks like a MAPI session limit, but I have tried the following from the MSKB, but this make no difference, the only other option to increase the MAPI session limit is a reg hack but this affect all users and I'm not prepared to do that. Any Ideas anyone ?


    - Grant the View Information Store Status Exchange permission to the
    account that the program runs under. Programs that run under an account
    that has this permission are not affected by the MAPI sessions per user
    limit. To grant the View Information Store Status permission, follow these

    1. In Exchange System Manager, right-click the Exchange Server object or
    the mailbox store that you want to grant the permission to, and then click
    2. Click the "Security" tab.
    3. Click the account that you want to grant the permission to.
    If the account is not listed, click "Add", click the account name, click
    "Add", and then click "OK".
    4. Under the "Allow" column, click to select the "View information store
    status" check box if it is not already selected.
    5. Click to clear the check boxes for any permissions that are not
    required, and then click "OK". You may have to perform this step because
    if you clicked "Add" to add the account in step c, every check box in the
    "Allow" column is selected.
    * Shamelessly mentioning "Don't forget to add reputation!"

  • #2
    Re: Exchange and SQLMail.


    I have this problem again, it seemed to go away but it seems that since this service account password was changed it's started happening again.

    Does anyone have any ideas what-so-ever.

    * Shamelessly mentioning "Don't forget to add reputation!"