Announcement

Collapse
No announcement yet.

Exchange 2k OWA Not Working for Migrated Mailboxes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange 2k OWA Not Working for Migrated Mailboxes

    Hi All,

    Any help here greatly appreciated. I have a client that I'm migrating their exchange 2k to a new Exchnage 2k box. I have already installed new exchange 2k server as second mail server in the administrative group and migrated 2 mailboxes from current server to new one for testing. Everything is working fine but the big problem i'm having now is accessing the two migrated mailboxes through OWA. When I put the OWA address, I get the login prompt, but when I put username and password, I guess page cannot be displayed. So exchange does not route OWA request between servers, so I tried using http://[newserverIP]/exchange and same thing happened even though I made all necessary firewall changes. I would love to migrate all mailboxes at same time then don't have to deal with this issue, but I have to do a phased migration because current server is in a different location and migrated users will need access to OWA as the project continues.

    So any solution for this? Is there configurations I have to make in new server's IIS to fix this. Any help will be greatly appreciated. Thanks.

  • #2
    Re: Exchange 2k OWA Not Working for Migrated Mailboxes

    Does OWA work locally?

    Certainly, from experiance, Exchange 2003 attempts to direct the request to the correct server. But obviously this will fail to users who are external as they can only ever see the one server that the NAT firewall points them to.
    Please remember to leave positive reputation points (The Ying Yang Icon) if someone helps you.

    Comment


    • #3
      Re: Exchange 2k OWA Not Working for Migrated Mailboxes

      Yes...it works locally. So do you think it's the firewall? the firewall is Checkpoint.

      Comment


      • #4
        Re: Exchange 2k OWA Not Working for Migrated Mailboxes

        It is the firewall but theres nothing you can do about it. I guess you can work around but making users use a non-standard port to get to the second exchange.
        EG

        https://owa.domain.net:88/owa

        Forward 88 traffic to 80 on the second server.
        If your moving all users why not move them and just reconfigure the firewall to point to the new server?
        Please remember to leave positive reputation points (The Ying Yang Icon) if someone helps you.

        Comment


        • #5
          Re: Exchange 2k OWA Not Working for Migrated Mailboxes

          Just to clarify what is happening here.
          If you have your mailboxes spread over two machines, then you will be able to use one or the other of the machines for OWA, not both, unless you put a third machine in front of them configured as a frontend server. Exchange will simply redirect the user to the correct machine, which will be an internal name.

          Another option is to have two IP addresses and have both machines exposed to the internet.

          The alternative port method may not work, as OWA is designed to operate only on port 80 and 443. Furthermore if you change the port in Exchange then you can break the functionality of certain parts of Exchange.

          Simon.
          --
          Simon Butler
          Exchange MVP

          Blog: http://blog.sembee.co.uk/
          More Exchange Content: http://exchange.sembee.info/
          Exchange Resources List: http://exbpa.com/
          In the UK? Hire me: http://www.sembee.co.uk/

          Sembee is a registered trademark, used here with permission.

          Comment

          Working...
          X