Announcement

Collapse
No announcement yet.

OWA error 500 - Internal server error / The specified module could not be found.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OWA error 500 - Internal server error / The specified module could not be found.

    I've got a installation of Exchange standard on two boxes, where mx1 is back end and mx2 is front end.
    I've been through these kbs: 829167, 301428, this thread, and a have been sifting throug event viewer, as well as resetting the virtual directories in iis at the servers.

    I just cant seem to get OWA working. The forms based login is showed in both ie and firefox, and their both able of authenticating to the servers. But that's also where everything stops. I've not been able of getting anything beyond here, other than "HTTP 500 Internal server error" in ie and "Error: The specified module could not be found".
    IIS-logs are as useless as no logs - just tells what request was recieved and what status it's returned...

    I tried running procmon at the same time as authenticating, hoping it would at lest tell me what file that's missing, but no such luck

    Anyone got ideas to what I'd check next?

  • #2
    Re: OWA error 500 - Internal server error / The specified module could not be found.

    Do you have forms based authentication on the back end box?
    If you do switch it off, it should only be on the front end.
    Last edited by Octagon; 22nd October 2008, 12:36.

    Comment


    • #3
      Re: OWA error 500 - Internal server error / The specified module could not be found.

      Hi, if u have a front end server then you need to access OWA via that.
      I.e http://mx2/exchange
      Try to enable ssl and try the same again
      https://mx2/exchange
      Please remember to award reputation points if you have received good advice.
      I do tend to think 'outside the box' so others may not always share the same views.

      MCITP -W7,
      MCSA+Messaging, CCENT, ICND2 slowly getting around to.

      Comment


      • #4
        Re: OWA error 500 - Internal server error / The specified module could not be found.

        I'm getting the same error message on both the front- and back-end, for both regular http as well as https.

        Comment


        • #5
          Re: OWA error 500 - Internal server error / The specified module could not be found.

          you don't need to go the back end.

          You should be connecting to the front end box which will handle the authentication.

          Make sure the forms based authentication is off on the back end.

          Comment


          • #6
            Re: OWA error 500 - Internal server error / The specified module could not be found.

            Reset the virtual directories on both servers using this KB article:
            http://support.microsoft.com/default.aspx?kbid=883380
            Ensure that require SSL is not enabled on either machine.

            Do not change anything and test again.

            Also ensure that both servers are at the same patch level. If the backend server went RTM, SP1, SP2 then the frontend server needs to do the same. However if the backend server went RTM, SP2 then you don't need to worry about it.

            Finally, ensure that you do not have asp.net 2.0 enabled for any of the virtual directories as asp.net framework is not backwards compatible.

            Simon.
            --
            Simon Butler
            Exchange MVP

            Blog: http://blog.sembee.co.uk/
            More Exchange Content: http://exchange.sembee.info/
            Exchange Resources List: http://exbpa.com/
            In the UK? Hire me: http://www.sembee.co.uk/

            Sembee is a registered trademark, used here with permission.

            Comment


            • #7
              Re: OWA error 500 - Internal server error / The specified module could not be found.

              did the "re-install" of OWA virtual directories per procedure from kb883380. Now I'm greeted with "HTTP/1.1 503 Service Unavailable" if I try connecting to either mx1 or mx2


              oh, btw: the servers are identically patched, both at 6.5.7638.1 atm
              Last edited by gulars; 22nd October 2008, 15:33. Reason: additional info

              Comment


              • #8
                Re: OWA error 500 - Internal server error / The specified module could not be found.

                Turn off show friendly http errors in the browser so that you can see the real error.
                That error is usually caused by an asp.net version issue.

                6.5.7638.1 is quite old - you don't have any of the patches for IE7 support.

                Simon.
                --
                Simon Butler
                Exchange MVP

                Blog: http://blog.sembee.co.uk/
                More Exchange Content: http://exchange.sembee.info/
                Exchange Resources List: http://exbpa.com/
                In the UK? Hire me: http://www.sembee.co.uk/

                Sembee is a registered trademark, used here with permission.

                Comment


                • #9
                  Re: OWA error 500 - Internal server error / The specified module could not be found.

                  Found it: Information store wasn't running at the back end. When I started that, the front end presented a fully functioning OWA window, while the back end is having some issues delivering images.

                  Thank you so much for your help

                  ps 503 service unavailiable isn't a "friendly" error, both ie and firefox displayed it. starting the store at back end fixed this.

                  Comment


                  • #10
                    Re: OWA error 500 - Internal server error / The specified module could not be found.

                    Do you not have any users on this environment then? Information Store is probably one of the last things I would have guessed as the problem because if IS isn't running then your users have no access to Exchange at all!

                    Simon.
                    --
                    Simon Butler
                    Exchange MVP

                    Blog: http://blog.sembee.co.uk/
                    More Exchange Content: http://exchange.sembee.info/
                    Exchange Resources List: http://exbpa.com/
                    In the UK? Hire me: http://www.sembee.co.uk/

                    Sembee is a registered trademark, used here with permission.

                    Comment


                    • #11
                      Re: OWA error 500 - Internal server error / The specified module could not be found.

                      It's a new domain, that we're prepping for migrating into, thus the only users in there right now is the admins and test accounts

                      But your right: if it where in production, we'd have a pile of pissed of users breathing down our necks

                      Comment

                      Working...
                      X