Announcement

Collapse
No announcement yet.

"There is no such object on the server" when expanding servers folder in AG

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • "There is no such object on the server" when expanding servers folder in AG

    Environment: Exchange 2003 SP2 (Native) on Windows Server 2003 R2 in an AD 2003 domain structure.

    I have a problem with my delegated "Exchange View Only Administrators". When opening ESM, Administrative Groups, AG-XXX, Servers, they recieve a message:
    "There is no such object on the server"
    Facility: Win32
    ID no: c0072030
    Exchange System Manager
    I'm pretty sure this is not a permissions error. This because I delegated permissions to my AG's. And this is working correctly. Exchange View Only Administrators can see and open the AG where they have permissions. This permissions are inhereted by the Servers in the AG. However, opening the Servers folder is not possible. I have added an Exchange View Only Admin to the local admins group on one of the Exchange servers and logged on locally but that resulted in the same error. My environment consists of 25 servers in 7 AG's. I have one central Exchange AG with several servers located in the toplevel domain called mydomain.net. Exchange View Only Admins are located in the subdomain.mydomain.net child domain. They are in a Universal group in their domain, and this Universal group is a member of a Universal Group in the top level domain. This universal group in the top level mydomain.net domain has been granted permissions by the Delegation of Control wizard. In this way, I want the delegated Exchange View Only Admins to log on to a local machine (e.g. a DC) to do their user and mailbox management.
    Full Exchange Administrators are not affected.
    It has been working in the past, and I'm not quite sure why it's not working anymore. The only thing that has been changed (to my knowledge) is applying some MS patches and removing some AG's and servers from the Exchange organization. Anyone has a clue? Any help would be greatly appreciated.

  • #2
    Re: "There is no such object on the server" when expanding servers folder in AG

    I was too fast with my assumption, it IS a permissions error. I mistakenly added a Deny entry on one of the servers in the AG that denied "List Object". I would expect just one server to be invisible but the error as described occurs then... Problem solved.

    Comment


    • #3
      Re: "There is no such object on the server" when expanding servers folder in AG

      Many thanks for posting back your findings.
      You could run the ExBPA to check permissions too.
      cheers
      Andy

      Please read this before you post:


      Quis custodiet ipsos custodes?

      Comment

      Working...
      X