Announcement

Collapse
No announcement yet.

local mail delivery queue, mail stuck

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • local mail delivery queue, mail stuck

    I have mail queuing in the local delivery queue with the queue state in retry.I tried forcing the connection but it doesn't deliver.I recovered this server from a catastrophic failure (IBM engineer comment) last week and mail was flowing perfectly at close of business Friday.Today the queue is stacking up and anyone who was working in cache mode and opened their mailboxes on Friday are not receiving mail.
    Running the BPA tool I get reports back of link state not registered and XEXCH50 not registered.When I telnet to the box output is as follows:


    ehlo
    250-mailgate.domain.com Hello [127.0.0.1]
    250-TURN
    250-SIZE
    250-ETRN
    250-PIPELINING
    250-DSN
    250-ENHANCEDSTATUSCODES
    250-8bitmime
    250-BINARYMIME
    250-CHUNKING
    250-VRFY
    250-X-EXPS GSSAPI NTLM LOGIN
    250-X-EXPS=LOGIN
    250-AUTH GSSAPI NTLM LOGIN
    250-AUTH=LOGIN
    250-X-LINK2STATE
    250-XEXCH50
    250 OK

    this looks to me like the verbs are recognised but BPA is reporting otherwise.Could this be causing the delivery problems locally?

  • #2
    Re: local mail delivery queue, mail stuck

    Looks like the link between SMTP and Exchange may have been lost.
    First thing I would do is cut off port 25 on the firewall, so that no email comes in.
    Then take the contents of the queue and store it elsewhere.

    You might get away with a reinstall of Exchange (and I mean selecting reinstall from Add/Remove programs). Then reinstall the service pack and any subsequent updates.
    Then try copying a queue message in to the PICKUP directory and see if it is delivered. If it is, then move the rest of the messages in to the same directory, which will mean Exchange will reprocess them.

    Then you can open port 25 on the firewall again.

    If that doesn't work, then it is a more serious problem.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: local mail delivery queue, mail stuck

      wouldn't this cause all local mail to be queued? some users are able to receive as normal. I can try the reinstall tonight.

      Comment


      • #4
        Re: local mail delivery queue, mail stuck

        Email that is between two users on the server then it doesn't cross SMTP.

        It would help if you stated whether it is ALL email, or what the pattern is, as the diagnosis for all email that is either inbound or outbound from external sources being stuck and just some is very different. I presumed that it was all.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: local mail delivery queue, mail stuck

          yeah sorry, a bit hazy with the description there.It is only certain users and it is all mail local and external.It looks almost like the mailbox isn't updating (cached mode) but on further tracking of the messages the mail is almost stuck in a loop.

          SMTP:Message delivered locally to [email protected]
          SMTP:Message scheduled to retry local delivery

          and so repeat until NDR is generated

          I am trying the reinstall as I type this.

          Comment


          • #6
            Re: local mail delivery queue, mail stuck

            Quick update on this one, the reinstall didn't make any difference so I went for a DR restore.Cut a long story short the hardware fault happened again!!!! Second IBM support call in a week and this time the tech finds a 'common' fault with our server configuration.New backplane being sent by courier and hardware engineer en route to fit it.Thanks Sembee for the input and suggestions.

            Comment

            Working...
            X