No announcement yet.

New Exch2003 server in Exch2000 site

  • Filter
  • Time
  • Show
Clear All
new posts

  • New Exch2003 server in Exch2000 site

    I am upgrading my server OS as well as Exchange Server from 2000 to 2003.

    I choose to do a migration path so I have a new W2K3 server that I intend to use Exch2003 on and then decommission the old W2K and Exch2000 pair.

    My servers are MDPW2KS1 and MDPW2K3S2 with the later being the new server.

    I have the new server and Exchange up and running without errors. I then created a new e-mail enabled user and set their mailbox to be on the new Exch2003 server. I then tried sending the new user a message from my workstation. That message stops in the message queue for the MDPW2K3S2 server on the MDPW2KS1 server.

    Opening up OWA on the new box and logging in as the new user I then attempted to send a message from that user to me. That message gets stuck in the queue for MDPW2KS1 on the MDPW2K3S2 box.

    I suspect that my problem is with my unique configuration as I use TZO as a mail relay and as such I have a Connector configured in my First (and only) Routing Group called Relay to Gateway. It is configured to forward all mail through this connector the following smart hosts and in the local bridgeheads I have only the original server listed. The address space for this connector is * with a cost of 2.

    I then added another SMT Connector which I named Intersite and added both servers to the list of local bridgeheads and the address space is set to (my public domain name) and the cost set to 1 and as well I added mdp.local to that address space (my internal AD forest domain name) also with a cost of 1.

    Restarting the Exchange services on both boxes and retesting sending mail did nothing but add more e-mail stuck in the queue.

    I checked my anti-spam filter and it is whitelisting the e-mail as it should.

    Using OWA and the new account on the new server I can send internet e-mail to my gmail account. But replying to that e-mail from GMail results in the message getting stuck on MDPW2KS1 in the MDPW2K3S2 queue.

    I can telnet in to MDPW2K3S2 from my workstation and send a message to the test account successfully. I cannot do the same by telnetting into MDPW2kS1.

    If I move the mailbox from the new box to the old one then all works as expected.

    For whatever reason, mail is not routing between the two exchange servers. I suspect it has to do with the routing groups and I suspect it is something really simple that is eluding me for some reason.

    Any ideas would be greatly appreciated.

    Thanks in advance.


  • #2
    Re: New Exch2003 server in Exch2000 site

    I solved my own problem.

    While I suspect the routing Connector changes were required I apparently had the virtual server configured on both machines to route through the smart host which I presumed overrides the connector settings. Clearing the smarthost config in the virtual servers resolved the problem.

    Of course I will have to remove the routing connector when I decommission the first server after moving the mailboxes, correct?

    Thanks in advance,