Announcement

Collapse
No announcement yet.

Public Folders error c103b404

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Public Folders error c103b404

    I've read a perfect article, named "How can I configure RPC over HTTP/S on Exchange 2003 (single server scenario)" (http://www.petri.com/configure_rpc_o...gle_server.htm)

    I made everything like it was told there - everethyng is working good exept one thing:

    when in system manager I'm tring to open or to create new public folder - I get an error:

    The SSL certificate server name is incorrect

    ID no: c103b404


    what I have:

    external ip that is showing my FQDN - iston.somedomain.ru
    inetrnal ip that is showing my LAN name - server.iston.local

    I use the certificate named iston.somedomain.ru, which is given by server.iston.local


    So do I need to rename my server (and to do all the work from the very beginning) into server.somedomain.ru to make public folders work?

  • #2
    Re: Public Folders error c103b404

    You have require SSL enabled somewhere that you shouldn't do - probably on the /public or /exchweb virtual directory. Remove the require SSL option and then run IISRESET.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Public Folders error c103b404

      I looked throgh my default web-site settings and found out that every part of a tree in catalog security is set to use SSL

      I turned it off everywere (public, OWA, exchange etc - ) exept exchadmin - the problem stayed

      In my default web site tree i have following categories:

      CertControl
      CertEnroll
      CertSrv
      Exadmin
      Exchange
      ExchWeb
      Microsoft-server-active-sync
      OMA
      Public
      RPC
      RPCWithCert
      aspnet_client

      Which of them should use ssl and which are not?
      Please explain.

      Comment


      • #4
        Re: Public Folders error c103b404

        Don't confuse REQUIRE SSL with using SSL. You do not need require SSL set anywhere.
        Therefore I would remove the setting from the root of the web site, then run IISRESET to write the change to the IIS metabase.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: Public Folders error c103b404

          Thank you, I've fixed the error, the problem surely was in setting SSL in all categories.

          But I made this SSL by the instruction:

          (How can I configure RPC over HTTP/S on Exchange 2003 (single server scenario)) - to make it work i needed to configure my website to use SSL.

          In this insruction (http://www.petri.com/configure_ssl_o...e_with_iis.htm) it was told in the part "To use the certificate to secure the web site that is using SSL":

          Note: It's also possible that you might not wish to protect the entire website, but merely one or two pages within the large website. In fact, this scenario is highly probable for most site operators that would only like to protect a couple or important pages, such as an online store or registration form. In that case you do NOT need to SSL-protect the entire site, so do NOT right-click the entire site. Right-click only the directory or pages within the site.

          So the problem was in my supidness in IIS - I really don't no where in the IIS tree I should ask for SSL.

          So for now I removed it everywhere - and I don.t know - if my SSL working in RPC over HTTPS or NOT/

          Comment


          • #6
            Re: Public Folders error c103b404

            You have confused the setting "require SSL" with the control of SSL.
            SSL is a per web site setting. Once it is installed on the site then it protects all the content. The Require SSL option simply controls whether IIS only allows connection over an SSL connection.

            RPC over HTTPS is designed to run over SSL, trying to get it to go over HTTP is very difficult.
            If you start Outlook and then hold down CTRL and right click on the Outlook icon, you should have an option "Connection Status". Select that and then you can see how Outlook is connecting.

            Simon.
            --
            Simon Butler
            Exchange MVP

            Blog: http://blog.sembee.co.uk/
            More Exchange Content: http://exchange.sembee.info/
            Exchange Resources List: http://exbpa.com/
            In the UK? Hire me: http://www.sembee.co.uk/

            Sembee is a registered trademark, used here with permission.

            Comment

            Working...
            X