Announcement

Collapse
No announcement yet.

RPC over HTTP not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RPC over HTTP not working

    Is there any way of testing RPC over HTTP internally? I would like to test out the new Exchange 2003 using RPC over HTTP internally without enabling SSL. Is there a way to do this?

  • #2
    Re: RPC over HTTP not working

    Setup your Outlook for it and make sure it can resolve the name (use a hosts file if you haven't setup split DNS). When you run outlook add the /rpcdiag switch and you should then be able to see it connect using https etc.

    http://www.petri.com/testing_rpc_ove...connection.htm
    cheers
    Andy

    Please read this before you post:


    Quis custodiet ipsos custodes?

    Comment


    • #3
      Re: RPC over HTTP not working

      Almost all RPC over HTTPS errors comes down to one of four things...

      1. Not meeting the requirements.
      Exchange 2003 on Windows 2003, Windows XP SP2 or higher with Outlook 2003 or higher, and at least one Windows 2003 GC.
      Windows 2000 will not work.

      2. SSL Certificate.
      Certificate not trusted or in the wrong name. Browse to https://host.doman.com/rpc from the client and see if you get a certificate prompt. If you do then the feature will not work.
      If you are trying to use a home grown certificate then stop now and use a commercial certificate. You will save yourself a lot of hassle.

      3. Registry Settings wrong.
      The registry settings on a single server can be tricky to get right. I know that Daniel has instructions here, but I can get this feature working in less than 30 minutes using my own. http://www.amset.info/exchange/rpc-http.asp

      4. Authentication mismatch.
      This is simply having Integrated Authentication enabled on the virtual directory and basic enabled in Outlook, or vice versa. Integrated Authentication is referred to as NTLM in Outlook.

      Simon.
      --
      Simon Butler
      Exchange MVP

      Blog: http://blog.sembee.co.uk/
      More Exchange Content: http://exchange.sembee.info/
      Exchange Resources List: http://exbpa.com/
      In the UK? Hire me: http://www.sembee.co.uk/

      Sembee is a registered trademark, used here with permission.

      Comment


      • #4
        Re: RPC over HTTP not working

        If you had posted in a separate thread then there wouldn't be the confusion over who the post was aimed at.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: RPC over HTTP not working

          Hi Sembee,

          Just to let you know, I have a CAS2007 with Outlook Anywhere enabled and my E2003 has RPC over HTTP enabled.

          1) Meeting all the requirements

          2) Connected to CAS2007.domain.local/rpc - received the Certificate prompt. I was thinking of using a homegrown certificate but can you recommend a commercial one?

          3) Never modified registry. Heard from somewhere that you didn't have to. I checked out your website but is not sure which registry setting I should modify. Should it be on the CAS2007 or E2003?

          4) I have my Authentication set to NTLM in Outlook and Integrated on the RPC virtual directory.

          Let me know how to proceed. Thanks.

          Comment


          • #6
            Re: RPC over HTTP not working

            The certificate prompt is a hard failure. The feature will never work.
            If you are using Exchange 2007 then you should have a SAN/UC certificate. You can get these for about US$60 from places such as GoDaddy (http://www.DomainsForExchange.net/) .

            The registry changes are only required if it is a standalone server. If you are using another server then you do not need to make registry changes, simply set the GUI in Exchange 2003 ESM and Exchange 2007 appropriately.

            Simon.
            --
            Simon Butler
            Exchange MVP

            Blog: http://blog.sembee.co.uk/
            More Exchange Content: http://exchange.sembee.info/
            Exchange Resources List: http://exbpa.com/
            In the UK? Hire me: http://www.sembee.co.uk/

            Sembee is a registered trademark, used here with permission.

            Comment


            • #7
              Re: RPC over HTTP not working

              Hijacked posts removed from this thread and that is the reason why there may appear to be inconsistencies with the information flow.
              1 1 was a racehorse.
              2 2 was 1 2.
              1 1 1 1 race 1 day,
              2 2 1 1 2

              Comment

              Working...
              X