Announcement

Collapse
No announcement yet.

IMF doesn't work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • IMF doesn't work

    I have Echange 2003 SP2. I think I configured all filters – by sender ID, by connection, by recipient and IMF too. I have activated all of them in the SMTP server.
    Although I have SCL set to 3 but I still have very much SPAM in all mailboxes.
    I think that my IMF doesn’t function. I set “When blocking message: Archive” but there isn’t any files in the directory: bin/vsi 1/UCEarchive.

    I made another test: with the admin tool Performance I tried to check the IMF, but… it doesn’t appear in the list. That’s why I think that something goes bad in my installation.

    Any idea to deal whit that?

  • #2
    Re: IMF doesn't work

    Before you start trying to fix this, change the block/archive from 3 to something like 7. At 3 it will block a lot of legitimate email.

    It could be that SMTP/IIS metabase hasn't been updated correctly.
    Turn off the IMF filter on the connection properties of the SMTP virtual server. Then close ESM and run iisreset in a command prompt. Then restart the SMTP Server Service.
    Then go back in to ESM and enable the filter option again, followed by running iisreset and restarting the SMTP virtual server.

    If you use perfmon does that show any filtering going on?

    How do you receive email? Direct SMTP delivery or via a POP3 connector?

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: IMF doesn't work

      Hi Simon,
      Thank you for replay.
      I did all this things - and nothing changes.

      I receive the mail via SMTP.
      And forgot to mention another thing - I receive automatic updates of IMF regularly from Microsoft, , so it should work somewhere....

      Comment


      • #4
        Re: IMF doesn't work

        The ability to receive updates from Microsoft for IMF and the functionality of IMF are two different things. Updates from Microsoft are part of the automatic updates system and are therefore like application updates.

        It sounds to me like the IIS metabase isn't being updated correctly.
        If you use perform, do the IMF counters show anything?

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: IMF doesn't work

          No, in the Perform I cant't find IMF - it is not in the list.

          Comment


          • #6
            Re: IMF doesn't work

            It is listed in Perfmon as its full name - Intelligent Message Filter. However the counters do have this habit of disappearing then reappearing seemingly at random. The feature continues to work correctly throughout.

            The feature isn't a bolt on. It was prior to Exchange 2003 SP2, but it was integrated with SP2. There is nothing to install and if the options show in ESM in all the required places then the install has occurred correctly. You could try reinstalling SP2 and then the hotfixes that are post SP2, however I suspect that there is something more serious wrong which may require more radical work.

            Simon.
            --
            Simon Butler
            Exchange MVP

            Blog: http://blog.sembee.co.uk/
            More Exchange Content: http://exchange.sembee.info/
            Exchange Resources List: http://exbpa.com/
            In the UK? Hire me: http://www.sembee.co.uk/

            Sembee is a registered trademark, used here with permission.

            Comment


            • #7
              Re: IMF doesn't work

              Thank you Simon to try help me...
              I suspected that reinstall all will be the best practice.
              Simply I was wandering if someone have had the same problem and try to resolve it without such radical work

              Comment


              • #8
                Re: IMF doesn't work

                IMF either works, or it doesn't. There is no middle ground and often a reinstall is the only way to resolve it.

                Simon.
                --
                Simon Butler
                Exchange MVP

                Blog: http://blog.sembee.co.uk/
                More Exchange Content: http://exchange.sembee.info/
                Exchange Resources List: http://exbpa.com/
                In the UK? Hire me: http://www.sembee.co.uk/

                Sembee is a registered trademark, used here with permission.

                Comment

                Working...
                X