Announcement

Collapse
No announcement yet.

Forcing internal emails to be delivered via internet

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Forcing internal emails to be delivered via internet

    Hello all,

    I am not sure if this is the right forum (sorry for also posting in the SBS forum), but here is my issue:

    My company is moving from one location to the other and will be operating out of both locations for at least a couple of months. In the old location, we have a SBS 2003 installation and are using exchange. In the new location, we also have a SBS installation up and running. Both locations are setup to be the same email address via recipient policies so user1 has [email protected] at both installations.

    The issue that we have is that when some of the users move to the new location, they will not be able to send out emails to the old location because the emails will bounce back since the users are not setup on the new location. The same goes for users at the old location trying to send emails to users at the new location.

    The emails themselves are not hosted by either location. Rather, we are using a provider and pull the emails into the server via MapiLab's POP Connector.

    OWA or RCP over HTTP is not an option at this time. So I am left with the task of figuring out how to get exchange to send out internal emails out to the internet as well. If they are delivered to the provider's mailserver, then my issues are solved because the POP connector will only pull the emails that are relevant to the specific server.

    Any ideas? Your help will be greatly appreciated.

    Thanks in advance,

    Jim

  • #2
    Re: Forcing internal emails to be delivered via internet

    Hi,


    Have you use track message in exchange to check where your message is going, and also you must be getting bouce back meesage with some error have you check tht?

    Comment


    • #3
      Re: Forcing internal emails to be delivered via internet

      The error message is simply that the user does not exist. The error message makes sense considering that the user is not defined in the new server and when I send an email to [email protected], Exchange will check to see if there is such a user in Company.com which there isn't.

      The problem seems to be that I can not force internal messages to be delivered via the internet.

      Jim

      Comment


      • #4
        Re: Forcing internal emails to be delivered via internet

        I may have found the solution. Can someone please confirm that this sounds right?

        In the Virtual SMTP Server properties, there is an option called "Forward all unresolved emails to Host". If I setup a sendmail or IIS SMTP on a different box in each one of the locations and enter that machine's IP into that setting would it mean that an unresolved email to [email protected] (UserB does not exist in Location A) that then Exchange will forward it to the smtp server which will then use the internet to send it? Or does that SMTP Server need to be outside of the domain so that it does the correct mx record lookup?

        Thanks again,

        Jim

        Comment


        • #5
          Re: Forcing internal emails to be delivered via internet

          To put it bluntly, SBS/Exchange is not designed to work in the way that you are trying to use it.
          The POP3 connector is only designed to assist with a move to SMTP delivery and SBS does not expect to have to work with another server.

          The solution you have identified will work, although it isn't ideal.
          Another method that would work is the dummy domain method, but that requires SMTP delivery, it doesn't work with POP3 connector.

          Simon.
          --
          Simon Butler
          Exchange MVP

          Blog: http://blog.sembee.co.uk/
          More Exchange Content: http://exchange.sembee.info/
          Exchange Resources List: http://exbpa.com/
          In the UK? Hire me: http://www.sembee.co.uk/

          Sembee is a registered trademark, used here with permission.

          Comment

          Working...
          X