Announcement

Collapse
No announcement yet.

Activesync 85010001 http 401

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Activesync 85010001 http 401

    I've been fighting this activesync issue for days - here are the details:

    * SBS 2003 migrated to new hardware
    * SSL is disabled - no certificate currently on server
    * Running WM5 emulator
    * Emulator can sync with other Exchange servers (so we know it's okay)
    * Checked Virtual directory permissions
    * Checked user account Exchange features - all enabled
    * Check credentials
    * Can successfully connect o OWA and OMA with same user credentials

    Activesync returns a status code of 0x85010001

    Server responses from the log on the device in order:

    http/1.1 401 unauthorized
    http/1.1 200 ok
    http/ 1.1 400 Bad request

    End of lines from IS logs:

    ...MSFT-PPC/5.1.2000 401 2 2148074254 405 321 15
    ...MSFT-PPC/5.1.2000 200 0 0 606 388 31
    ...MSFT-PPC/5.1.2000 400 0 0 312 445 15

    I know I'm missing something - please help...

    Thanks,
    jv

  • #2
    Re: Activesync 85010001 http 401

    Trying to get this feature to work without SSL is, in my opinion, a waste of time. It is perfectly possible to get it to work without SSL, introduce the certificate and everything breaks.
    Furthermore SBS is designed to be used with a certificate and makes changes to the system to take that in to account.

    Therefore I would suggest two courses of action.

    1. Purchase a commercial SSL certificate that is trusted by Windows Mobile. The trust of Windows Mobile rules out all free options.
    2. Run the Connect to the Internet and Email wizard on SBS again until it completes successfully to ensure that the server is configured correctly.

    You should not be configuring SBS manually and making changes to the IIS configuration outside of the wizard will usually cause more problems than it fixes. SBS should be treated as an appliance and where possible use the wizards.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Activesync 85010001 http 401

      Simon - thanks.

      I've put back the Equifax certificate. However, when I run the wizard - it opens the first screen and then just quits when I hit next. Any thoughts on that?

      jv

      Comment


      • #4
        Re: Activesync 85010001 http 401

        More info - there were 3 config.vbs scripts and related htm documents in the sbs/networking/icw directory - I moved them but the wizard still won't run...

        Comment


        • #5
          Re: Activesync 85010001 http 401

          I am not an SBS expert - you may want to post a question in the SBS forum. The fact that the wizard will not run is a sign that all is not well with the server, which may well be at partially to blame for your problems.

          Simon.
          --
          Simon Butler
          Exchange MVP

          Blog: http://blog.sembee.co.uk/
          More Exchange Content: http://exchange.sembee.info/
          Exchange Resources List: http://exbpa.com/
          In the UK? Hire me: http://www.sembee.co.uk/

          Sembee is a registered trademark, used here with permission.

          Comment


          • #6
            Re: Activesync 85010001 http 401

            It could be worth re-applying the service packs for server and exchange.

            Is it also worth resetting the vdirs?
            http://support.microsoft.com/kb/883380
            cheers
            Andy

            Please read this before you post:


            Quis custodiet ipsos custodes?

            Comment

            Working...
            X