Announcement

Collapse
No announcement yet.

Setting up SMTP for access/authentication for outside users (using imap/smtp/ssl)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setting up SMTP for access/authentication for outside users (using imap/smtp/ssl)

    Running Exchange 2003. I have a valid SSL certificate for the domain I am
    using. I have a half dozen users outside the office that use IMAP to get
    their mail. I am trying to configure an SMTP Virtual Server in exchange for
    them to send mail. (SMTP on port 465 using the valid SSL cert.)

    I can't figure out the proper settings to make it work. I need it to require
    authentication. The SSL part negotiates ok, but I think it's bombing out on
    the authentication part. I've set this type of thing up in IIS before and
    never had any issues with it.

    Any clues?

    I just removed my virtual server and recreated it to make sure the settings
    aren't all out of whack.

    Port 465 is set. SSL is set up.
    I have given the user (Administrator is this case, just for testing) Submit
    and Relay permission
    I have added ED as the default domain under "authentication"

    What else do I need to do? Still have the same error at this point.

  • #2
    Re: Setting up SMTP for access/authentication for outside users (using imap/smtp/ssl)

    What error are you getting?
    What format are you passing the username in?

    username
    domain\username
    [email protected]

    something else?

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Setting up SMTP for access/authentication for outside users (using imap/smtp/ssl)

      Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Subject 'ED SSL TEST ', Account: 'mail.domain.com', Server: 'mail.domain.com', Protocol: SMTP, Port: 465, Secure(SSL): Yes, Error Number: 0x800CCC0F


      I'd settle to just use the auto-created virtual server at this point. People are telling me that by default they are set up for authenticated relay. I don't believe this is actually the case.

      I've tried all combinations of username/password for SMTP. I connect to the same server w/ IMAP/S and that part works great.

      Comment


      • #4
        Re: Setting up SMTP for access/authentication for outside users (using imap/smtp/ssl)

        Authenticated relaying is enabled by default in Exchange 2000 and 2003. You can see the option in Relay settings under the properties of the SMTP virtual server in ESM.

        The combination that you should be using is domain\username.

        If you telnet to port 465 do you get the SMTP banner?
        If you then issue a ehlo, is STARTTLS listed?

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment

        Working...
        X