Announcement

Collapse
No announcement yet.

Directory not connecting for rpc/http clients

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Directory not connecting for rpc/http clients

    Hello,

    Thanks in advance for any assistance. I've used this site for reference for years and this is the first time I've needed to start a thread.

    Here goes. I have a single-server rpc/http exchange server that has been running fine for some time. The exchange server is a domain controller and a global catalog. It is not the primary domain controller but at one time it was. We replaced our PDC with a new machine and did all the usual transferring around of roles and everything works fine.

    We have had some odd issues with the RPC/HTTP users. Some can't print when connected or post to private folders. To work around they are able to go offline, print or post, and then go back online.

    On the RPC/HTTP clients the connection status looks like this http://i274.photobucket.com/albums/j...able75/rpc.jpg

    As you can see the directory isn't connecting but the rest is.

    I've done lots of searching on this but unfortunately all searches lead to folks that can't connect at all.

    Thanks,

    Tim

  • #2
    Re: Directory not connecting for rpc/http clients

    Have you made the registry setting required for the domain controller?
    If the Exchange server is installed on a domain controller, it is also a global catalog? If not then it must be. Furthermore the RPC over HTTPS settings should be pointing back to the Exchange server only. It cannot use any other domain controllers.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Directory not connecting for rpc/http clients

      Thanks for the reply.

      I did make the registry changes on it. I did the rpcnofrontend tool as well as added the 'domain controller' key. Just to be sure we're on the same page, can you refer to what keys should be set and I'll post what they are?

      The exchange server does point to itself for address books and everything. When you say "the RPC over HTTPS settings should be pointing back to the Exchange server only" what exactly do you mean?

      The exchange server is a GC.

      thanks!

      Comment


      • #4
        Re: Directory not connecting for rpc/http clients

        The following should be on the domain controller.

        Windows Registry Editor Version 5.00

        [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\NTDS\Parameters]
        "NSPI Interface protocol sequences"=hex(7):6e,00,63,00,61,00,63,00,6e,00,5f ,00,\
        68,00,74,00,74,00,70,00,3a,00,36,00,30,00,30,00,34 ,00,00,00,00,00

        All other entries should only be referencing the Exchange server - so where servers are listed it should be just the Exchange server.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: Directory not connecting for rpc/http clients

          The exchange server is the domain controller.

          I do have that key imported and it I have under hklm/system/ccs/services/ntds/parameters a multi string key with the value ncan_http:6004

          The other related key I have is: hklm\software\microsoft\rpc\rpcproky with a string value of fillmore:6001-6002;fillmore.annableconsulting.com:6001-6002;webmail.annableconsulting.com:6001-6002;fillmore:6004;fillmore.annableconsulting.com: 6004;webmail.annableconsulting.com:6004

          Note, fillmore is the name of the exchange server, its full name is fillmore.annableconsulting.com
          and the outside address that the cert points to is webmail.annableconsulting.com

          Comment

          Working...
          X