Announcement

Collapse
No announcement yet.

OWA Redirect Loop

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OWA Redirect Loop

    Hi all, I've been using the fantastic site and forums as a lurker for a while.

    Last night I decided to install a second Exchange 2003 server to help offload some of the email from the primary one, with an aim to defragging (it's gotten so large the downtime from using eseutil would be nasty).

    I learned that if I have POP3 users and webmail users and I don't want a small support nightmare I'm best with a front end server (in fact I would've been better with one to start with) so I installed a 3rd Exchange 2003 server also.

    My setup:

    - Win 2000 AD Domain (single domain)
    - Primary Exch 2003 SP2 Server
    - Secondary Exch 2003 SP2 Server
    - Front end Exch 2003 SP2 Server

    All Exchange servers are running Win 2003 Standard and are all on the same subnet, none of them are in a DMZ or anything tricky.

    The heart of my question/problem is that the front end server is working fine with POP3 and can see any mailbox no matter what server. I moved 3 or 4 mailboxes to the secondary server for testing. Outlook works fine, POP3 is fine.

    I setup OWA with FBA and with an SSL Cert and it works perfectly well if the mailbox is on the secondary server. If the mailbox happens to be on the Primary server, I end up with a redirect loop error.

    I can get to the primary server using it's own OWA interface that was exisiting before all this but when I try with the Front end I get the loop. I get the feeling it's trying to lookup something in DNS thats either failing or looping but nothing obvious to me.

    I apologize if I left out any key info, I'd be grateful for any ideas on this one!

    With thanks,

    - Frank

  • #2
    Re: OWA Redirect Loop

    Has there been any customisation of OWA on the original server? Changes to remove the need for /exchange for example?

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: OWA Redirect Loop

      Actually good point, I do.

      I have it so that users going to the root URL will be redirected to /exchange. I also have it so that users going to the http:// root will be redirected to the https:// /exchange site.

      - Frank

      Comment


      • #4
        Re: OWA Redirect Loop

        You have to remove all of the customisation on the original server. That will be the cause of the problem.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: OWA Redirect Loop

          Giving that a try right now, thanks Simon!

          - Frank

          Comment

          Working...
          X