Announcement

Collapse
No announcement yet.

iPhone not connecting to 2003

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • iPhone not connecting to 2003

    I've followed the instructions all over the web thru searching on google and in the iPhones book, but I am still unable to get the iPhone to talk to the Exchange.

    It started with just not being able to find the server at all, but I soon worked out that was because of the ports no being open on our Cisco firewall. I've set that up now, but I get the following on the phone;
    It firstly says Cannot connect using SSL, would I like to try without, to which I could say yes and then I get username or password incorrect for "mailgate.{domain}". IMAP must be enabled.

    IMAP is enabled, OWA address is "mailgate.{domain}/exchange", IMAP and SSL ports are open and I'm now struggling to work this out, especially as everywhere i read it says that this is easy to do!

    Any ideas?
    James
    MCP

  • #2
    Re: iPhone not connecting to 2003

    I've managed to solve the SSL issue, but the username and password issue still exists. I am using the format of {domain}/{user}.
    James
    MCP

    Comment


    • #3
      Re: iPhone not connecting to 2003

      No idea if this is worth trying but just from what you have written have you tried "\" rather than "/" or [email protected]l ?
      cheers
      Andy

      Please read this before you post:


      Quis custodiet ipsos custodes?

      Comment


      • #4
        Re: iPhone not connecting to 2003

        thats probably just my dodgy typing, but yes I have tried all of those.... not to mention {domain}/{user}/{alias} and with \ as well..... just on the off chance....
        James
        MCP

        Comment


        • #5
          Re: iPhone not connecting to 2003

          Dodgy typing rules..

          have you tried another client like thunderbird or Outlook Express?
          Does it work internally to the server (I'm guessing Exchange 2003?)
          If so then I would look at the firewall again, can you get the logs from it?
          cheers
          Andy

          Please read this before you post:


          Quis custodiet ipsos custodes?

          Comment


          • #6
            Re: iPhone not connecting to 2003

            Check out Mark Wilson's post about this:

            http://www.markwilson.co.uk/blog/200...nge-server.htm

            Michael
            Michael Armstrong
            www.m80arm.co.uk
            MCITP: EA, MCTS, MCSE 2003, MCSA 2003: Messaging, CCA, VCP 3.5, 4, 5, VCAP5-DCD, VCAP5-DCA, ITIL, MCP, PGP Certified Technician

            ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

            Comment


            • #7
              Re: iPhone not connecting to 2003

              Andy, other clients are fine - OWA, OMA, outlook, whatever - both internally and externally. Yes 2003. Firewall is fine I triple checked and the ports are forwarding to the server.

              Michael, Yeah i've read that, but still had the problem. Tho it is now moved on a bit.....

              Ok, I deleted the account from the iPhone. Removed the Cert from IMAP, reapplied. reentered the accounts settings..... it connected! So he can receive his mails now, but cant send. I'll take another look at this a little later on, but he os half happy as he is receiving.

              Gotta move onto why some Scheduled tasks are starting but not initializing now, so depends on how that goes...

              Cheers for the help though guys
              James
              MCP

              Comment


              • #8
                Re: iPhone not connecting to 2003

                Ah good news!
                If sending is a problem then check authenticated users are allowed to use the smtp server or see if you can use your ISP (phone suppliers) smtp maybe?
                cheers
                Andy

                Please read this before you post:


                Quis custodiet ipsos custodes?

                Comment

                Working...
                X