Announcement

Collapse
No announcement yet.

OWA Login problem.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OWA Login problem.

    Hey,

    I'm experiancing a strange problem in that only Admins can login to OWA.

    Obviously I don't want to make my all my users admins so was wondering if anyone has had a similar problem.

    The original install of this server wasn't great and I have had to reinstall alot of the original SBS componants.

    The permissions look ok in IIS, although they don't seem to be inherited as they aren't grayed out. Everything also looks fine in Exchange on the HTTP side.

    I am using FBA, but doesn't make a difference if it's turned off.

    I'm really starting to scratch my head with this one so any help would be greatly appreciated.

    Cheers
    Dean

  • #2
    Re: OWA Login problem.

    You've probably already checked this, but when is OWA enabled on their accounts? Can't imagine what else could be causing the problem. What's the error message?

    Comment


    • #3
      Re: OWA Login problem.

      Thanks for the reply.

      Yes OWA is enabled on all users in ADUC and the HTTP VS is running in ESM.

      Another wierd porblem is that it is only the Administrator account that can log into OWA. Even is I setup another DA account it errors the same as the rest.

      The error just says "You could not be logged on to Outlook Web Access. Make sure your domain\user name and password are correct, and then try again." in red above the login box.

      Very frustrating!

      Comment


      • #4
        Re: OWA Login problem.

        have you modified anything in IIS after the install?

        if so, what method (put a link) here to show us the process.

        sounds like the permissions are not correct on the IIS directories.

        or did you modify the "domain\uname" logon portion of OWA?

        you could remove and re-create the directories on both the front-end and back so the permissions are correct, then try again.

        that is if you have a front-end. we dont even know what version your running... i think the exchange is installed on SBS, yes? info, info, info...

        what im getting at is this is not the default behavior and something got changed... its just hard to pinpoint without any information... give us a few clues as to what happened post-install.
        its easier to beg forgiveness than ask permission.
        Give karma where karma is due...

        Comment


        • #5
          Re: OWA Login problem.

          Hi James and thanks for your reply.

          As I said in my first post, the initial install of the SBS server wasn't great as a lot of the SBS components seemed to have been left out. I went onsite on Tuesday and installed the missing compnents which allowed me to run the CEICW and publish OWA.

          As far as I could see OWA wasn't working correctly internally beforehand, but think this was SSL issues rather than anything else.

          While onsite I was using the Administrator account so didn't notice a problem, since then client has reported the issue.

          Users can log into RWW fine, so IIS is working, but they are still unable to read their email. If they click on the email link within RWW they get prompted with the OWA username and password screen.

          I have also tried browsing to other users mailboxes once logged into OWA as Administrator, but it says page not found.

          I have removed and re-added the OWA VD's in IIS, but no joy. I have also reinstalled Exchange SP2 with the same result, nada!!

          I am just downloading the Best Practises tool to see if that unearths anything!

          Cheers
          Dean

          Comment


          • #6
            Re: OWA Login problem.

            thats a good thing to do. the BPA will give you a better idea of where the problem is than us guessing.

            let us know what happens.

            James
            its easier to beg forgiveness than ask permission.
            Give karma where karma is due...

            Comment


            • #7
              Re: OWA Login problem.

              Dean,

              Have you installed a certificate and configured SSL?

              Zoey

              Comment


              • #8
                Re: OWA Login problem.

                An SSL certificate will not be the cause of this. And as this is SBS there will be an SSL certificate already in place - a home grown certificate.
                Has it ever worked?

                This usually caused by a permissions problem. Resetting the virtual directories usually fixes the problem: http://support.microsoft.com/default.aspx?kbid=883380

                It is important that after resetting the virtual directories that you run the Internet and Email wizard again and it must complete successfully. Not running the wizard will cause things to fail.

                Simon.
                --
                Simon Butler
                Exchange MVP

                Blog: http://blog.sembee.co.uk/
                More Exchange Content: http://exchange.sembee.info/
                Exchange Resources List: http://exbpa.com/
                In the UK? Hire me: http://www.sembee.co.uk/

                Sembee is a registered trademark, used here with permission.

                Comment


                • #9
                  Re: OWA Login problem.

                  Thanks again for the comments and ideas.

                  I managed to fix it, the problem was security permissions on folders in the Exchsvr folder. The following document proved very handy http://support.microsoft.com/kb/327843/en-us

                  I had to add Authenticated Users into the ExchWeb folder with Read & Execute, List and Read permissions. I also had to do the same for bin and RES in the same folder, but also had to give SYSTEM Full Control.

                  Thanks again for your replys, just glad it's working!

                  Cheers
                  Dean

                  Comment


                  • #10
                    Re: OWA Login problem.

                    Thanks for posting back Dean and sharing your solution. It is greatly appreciated.
                    1 1 was a racehorse.
                    2 2 was 1 2.
                    1 1 1 1 race 1 day,
                    2 2 1 1 2

                    Comment

                    Working...
                    X