Announcement

Collapse
No announcement yet.

Problem with sending e-mail to specific domain.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with sending e-mail to specific domain.

    We are sending e-mails to one company and they never get there.
    We get bounced mail with the following error:
    The following recipient(s) cannot be reached:
    Could not deliver the message in the time limit specified. Please retry or contact your administrator
    <server.mydomain.com #4.4.7>
    Our server is exchange 2003 SP2
    Anybody has any idea?

  • #2
    Re: Problem with sending e-mail to specific domain.

    This is from an article on the MS web site:

    • Numeric Code: 4.4.7

    Possible Cause: The message in the queue has expired. The sending server tried to relay or deliver the message, but the action was not completed before the message expiration time occurred. This NDR may also indicate that a message header limit has been reached on a remote server or that some other protocol timeout occurred during communication with the remote server.
    Troubleshooting: This code typically indicates an issue on the receiving server. Verify the validity of the recipient address, and verify that the receiving server is configured to receive messages correctly. You may have to reduce the number of recipients in the header of the message for the host that you are receiving this NDR from. If you resend the message, it is placed in the queue again. If the receiving server is on line, the message is delivered.


    Try telnetting to the recipient's server and see what you get. Typically this problem occurs because of a problem on the receiving side.

    Comment


    • #3
      Re: Problem with sending e-mail to specific domain.

      I’ve tried to telnet from couple other different exchange servers (different companies).
      telnet works fine, but from the company that has problem telnet doesn’t work “failed”
      I read that article on Microsoft, is there a way to raise the timeout period?

      Comment


      • #4
        Re: Problem with sending e-mail to specific domain.

        If you can't telnet to the recipient server then the problem is on their end and I would suggest that you not modify your server to "fix" their problem. If you really want and need to increase the timeout period it can be done from the Delivery tab of the properties of the SMTP virtual server. Set the Outbound expiration timeout to whatever you think is appropriate.

        Comment


        • #5
          Re: Problem with sending e-mail to specific domain.

          I can't telnet only from the problematic server.
          From other places telnet is working perfectly.

          Comment


          • #6
            Re: Problem with sending e-mail to specific domain.

            Firewall blocking access from that particular server on remote site ?
            Leave 'reputation' when deserved :

            Comment


            • #7
              Re: Problem with sending e-mail to specific domain.

              I don’t think it's a firewall, since from the problematic exchange server I can telnet other ones except for the one I have problem with.
              Only from the exchange that has problem sending e-mails to that company, telnet doesn't work.

              Comment


              • #8
                Re: Problem with sending e-mail to specific domain.

                I don't know how to be any clearer about this:

                If you cannot telnet to the server you are trying to send email to and if you cannot send an email to that domain, then it is their problem not yours.

                Stop trying to "fix" it on your side. The problem is on their side.

                Can you clarify the following:

                1. From your mail server you cannot telnet to their mail server.
                2. From your mail server you can telnet to other mail servers.
                3. You cannot send an email to them.
                4. You can send email to others.

                Comment


                • #9
                  Re: Problem with sending e-mail to specific domain.

                  The answer is yes to all 4 questions.
                  However, I configured bunch of exchange servers for different companies with the same settings.
                  All of them can telnet to that company except one.
                  Doesn’t make sense

                  Comment

                  Working...
                  X