Announcement

Collapse
No announcement yet.

Transaction logs don't flush after full backup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Transaction logs don't flush after full backup

    Hello, I was called in over the weekend because our email was down. After some research I found that the C:drive was full 0 bytes free. After some searching and I found that he exchange transaction logs were taking up about 7GB of space, and then later I found that the "C:\System Volume Information\catalog.wci" was taking about 9GB.

    I manually moved the transaction logs over to the F: drive and rebooted, I gained that space plus an additional 2.5 - 3GB with the reboot. I manually moved the transaction logs back and ran a full information store backup with Backup Exec. 10

    This did not flush the logs, so not knowing any better I did a second backup which included the information store, and the c:\Program Files\Exchsrvr\MDBDATA folder. Still did not flush the logs.

    I dismounted the store and changed the storage path to the F:drive and allowed exchange to move the files. After that completed I ran a full backup of the information store. While that was running I stumbled across the catalog.wci folder so I shut off the indexing service and deleted the whole directory then restarted the index service.

    My daily backup of exchange is full database, differential on mailbox's. My weekly is full on both. My transaction logs date back to 1/27 (almost 3 weeks now).

    We are running sbs2003 standard. Thanks for any advice in advance

  • #2
    Re: Transaction logs don't flush after full backup

    The first thing I always suggest when backups fail to flush the logs is use NTBACKUP to backup Exchange only. That can be a backup to disk for example. See if that will flush the logs. If it fails, then something is usually logged.

    The problem you are going to have is that you moved the logs files manually. That was not a good thing to do. If you are going to move the logs then you should do it through ESM. In an emergency, to gain space you can compress the transaction logs only - do not compress the directory. That will usually give you enough space to get things working so you can either move the files or do a backup. Then you can turn off compression.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: Transaction logs don't flush after full backup

      I did move the logs manually, but then put them back after a reboot. In the end I used the Exchange system manager to move the directory.

      I will have to put Veritas on hold for tonight and allow NT Backup to run hopefully this clears up the problem.

      Do you think that running the NT Backup will kick start the process and after 1 nt backup I can resume my normal procedures using Veritas?

      I was reading a howto: on NT Backup one of the notes I am confused about says that this type of backup requires circular logging, I do not have that enabled should I enable that temperarly?

      Thanks
      Last edited by stylus277; 11th February 2008, 18:13.

      Comment


      • #4
        Re: Transaction logs don't flush after full backup

        In most cases NTBACKUP will resolve the problem and allow Backup Exec to work correctly in the future.

        Where are you reading about circular logging? That isn't correct. Circular logging is not required and I would NOT recommend that it is enabled.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: Transaction logs don't flush after full backup

          NT Backup worked partially, I had logs from 1/28 - Current. Running the NT backup cleared logs from 2/9 - Current. I just deleted the ones between 1/28 and 2/9.

          Time will tell if the problem is 100% resolved but I suspect it is.

          Thanks for the help.

          Comment

          Working...
          X