Announcement

Collapse
No announcement yet.

"External email addresses" not showing in GAL

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • "External email addresses" not showing in GAL

    Hey all,

    I have an Exchange 2000 server, and recently was asked to add two contacts into Exchange DLs and Contacts-->External Email Addresses. The two contacts have email addresses that are NOT from one of our domains.

    After two days, these addresses are still not searchable when I compose a new message, click To:, and search the global address list.

    I'm new to managing Exchange, but did a bunch of searching on this forum and checked a few basics: the Recipient Update Service is running every morning at 6 a.m., and I did try doing a manual download of the GAL with my Outlook client to ensure I was receiving the latest info. I also checked that these new contacts I added are replicating to both our DCs.

    The GAL contains many contacts that have email addresses outside of our domain, so I don't understand why my newest additions aren't popping up! Any ideas?

    Brian

  • #2
    Re: "External email addresses" not showing in GAL

    open eX sys-manager, highlight RUS and update both the enterprise and domain entries located on the right... its preferably to go ahead and rebuild it, but this will effect server performance depending on your user base and mail flow patterns, so be warned...

    that should do the trick.

    you arent using cached mode are you?

    J
    its easier to beg forgiveness than ask permission.
    Give karma where karma is due...

    Comment


    • #3
      Re: "External email addresses" not showing in GAL

      James,

      Wow - you totally helped me on my last post too. You're EVERYWHERE dude!

      Ok, I did an update on both the enterprise and domain objects, then did Tools-->Send/Receive-->Download Address Book (because I AM using cached mode). I still don't see those dudes in the GAL.

      I will try a rebuild during off-hours. Do you know if you get any kind of status/progress bar during that procedure? Because updating the enterprise/domain objects never showed me they were running...but in Properties-->Details Tab I could see that the modified time was just a few minutes ago.

      Thanks,
      Brian

      Comment


      • #4
        Re: "External email addresses" not showing in GAL

        Unless you have 1000s of contacts, a rebuild doesn't take that long.
        Can you see the contacts in the LIVE GAL? You can either look through ESM or OWA.
        Are you using any kind of custom address books?

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: "External email addresses" not showing in GAL

          Hey Sembee,

          I don't see the two new addresses in OWA, and in Exchange Manager I attached a pic of what I have under the Recipients tree...does this answer your question about custom address books? If I click ANY of the entries you see in the picture, NOTHING loads to the right. But yet...we DO have an address book full of people, so...(sorry to sound so newbish )

          I'll do the rebuild of the enterprise/domain entries tonight, but let me know if there's anything else I should do/try.

          Thanks guys,

          Brian
          Attached Files

          Comment


          • #6
            Re: "External email addresses" not showing in GAL

            If you don't see the addresses in OWA, then you will not see them in Outlook.
            Have the objects got automatic email addresses as well? They should have an X.400 address and an address in your default domain. If not, then Recipient Update Services isn't working correctly.

            Simon.
            --
            Simon Butler
            Exchange MVP

            Blog: http://blog.sembee.co.uk/
            More Exchange Content: http://exchange.sembee.info/
            Exchange Resources List: http://exbpa.com/
            In the UK? Hire me: http://www.sembee.co.uk/

            Sembee is a registered trademark, used here with permission.

            Comment


            • #7
              Re: "External email addresses" not showing in GAL

              Hey Sembee,

              Well, these two new contacts are in the Exchange DL's and Contacts-->External Email Addresses folder, so when I open the properties of each item I don't see any X400 address. There is just a General, Address, Telephones, Organization and Member Of tab. All that's filled out is the First/Last/Display Name and Email Address on the General tab.

              There are tons of other contacts in this folder setup the same way, and their addresses DO show up in the GAL. Sigh.

              Oh, by the way I kicked off the rebuild of the two items in the Recipient Update Services folder. How would I know when this is done? I guess I'll just check again in the morning by forcing a download of the address book to my client again and hopefully they'll be there!

              Brian

              Comment


              • #8
                Re: "External email addresses" not showing in GAL

                Gargh! After kicking off the rebuild last night around 10 p.m., I forced an update of the GAL on my Outlook client and those two addresses are STILL not showing up. Please shoot any more thoughts you guys have...I'm all ears!

                Brian

                Comment


                • #9
                  Re: "External email addresses" not showing in GAL

                  When you preview the GAL from ESM do the contacts show up? If not, then the filter used to populate the GAL is not a valid filter for these contacts (meaning there is something wrong with the contacts). Have you modified the filter on the GAL in any way?

                  Comment


                  • #10
                    Re: "External email addresses" not showing in GAL

                    Hey Joe,

                    See a few posts higher in this thread...I have a whole tree of address lists, and when I click any of them on the left, I see NOTHING on the right. However, my GAL *is* populated with all kinds of addresses, so I don't think I'm looking in the right place. If you can put on your "newbie helper" hat and handle me gently, I'd appreciate it

                    Brian

                    Comment


                    • #11
                      Re: "External email addresses" not showing in GAL

                      You don't and won't see anything in the right pane when selecting an address list. What you need to do is open the properties of the address list and click the preview button from the general tab. After doing this, do you see the contacts in question?

                      Comment


                      • #12
                        Re: "External email addresses" not showing in GAL

                        Joe,

                        Ah! Now we're getting somewhere. Ok, under Recipients-->All Global Address Lists-->Customers I see all sorts of external contacts that we setup previously when I look at Preview, but I DON'T see my two new contacts.

                        When I do a Modify of that, I see that what is checked is "Contacts with External Email Addresses," which is EXACTLY what my two new entries are. I still must be missing something obvious, eh?

                        Brian

                        Comment


                        • #13
                          Re: "External email addresses" not showing in GAL

                          OK. Do the contacts have X400 addresses? Is the external email address set as the primary SMTP address?

                          Also, does the filter look like this:

                          (&(&(& (mailnickname=*) (| (&(objectCategory=person)(objectClass=contact)) ))))
                          Last edited by joeqwerty; 4th February 2008, 16:29.

                          Comment


                          • #14
                            Re: "External email addresses" not showing in GAL

                            Hi Joe,

                            When I look at the properties of any of those contacts, these are the only tabs they have...and only the first/last/display name and email address are filled in...so there is no X400 address to be seen in these tabs...

                            Brian
                            Attached Files

                            Comment


                            • #15
                              Re: "External email addresses" not showing in GAL

                              That's the problem then. These objects are not mail enabled and therefore will not show up in the GAL. Right click each contact, then select Exchange Tasks, then select Establish E-mail Address, then click the modify button to create the external SMTP address. After that they should be OK.

                              Comment

                              Working...
                              X