Announcement

Collapse
No announcement yet.

Error 3029, even though OMA works!!?!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error 3029, even though OMA works!!?!

    Hi Everyone,

    First of all, a big thank you to everyone involved with this site. The info provided here is absolutly top notch.

    I am a new Exchange admin, so when I had to setup OMA, I followed the guides provided here on Petri.co.il. OMA is working great and I don't know how I lived without it! However, I am still getting Error 3029 in Event Viewer. When I open the event, I am told that my OMA Directory (/ExchangeDAV) is set to require SSL and Exchange ActiveSync will not work in this configuration. I have checked the settings and /ExchangeDAV is not set to require SSL and it works great. I am just a little unhappy seeing those hundreds of errors every time I open Event Viewer.

    Any suggestions?

    Thanks,

    Edgar

  • #2
    Re: Error 3029, even though OMA works!!?!

    have you check this KB?
    Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003

    am i correct in assuming that you are not using a front end server? if so, then pay close attention to the second solution (Method 2) on steps to modify the registry to correct this problem in a single exchange server environment.

    lemme know if that solution is not applicable to your situation.

    James
    its easier to beg forgiveness than ask permission.
    Give karma where karma is due...

    Comment


    • #3
      Re: Error 3029, even though OMA works!!?!

      James,

      Thanks for the quick reply! I did follow KB817379 when I first setup OMA, but I went back just to make sure I did not miss something. Unfortunately I was not able to find any problems.

      Also, as you asked, I am running without a Front-End Server (only one server).

      Is there anything else I should be looking for?

      Thanks,

      Edgar

      Comment


      • #4
        Re: Error 3029, even though OMA works!!?!

        817379 has some flaws, if done as it states with FBA enabled then the config that causes the problem comes across. l have written my own version which gets round that problem: http://www.amset.info/exchange/mobile-85010014.asp

        Simon
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: Error 3029, even though OMA works!!?!

          Sembee,

          Thanks for the great article. I think I have made some progress! Also, thanks for the great tip about the difference between requiring SSL and using SSL. I really thought that if you did require SSL, you could not use it. If followed your advice and placed a deny port 80 rule on my firewall (even though it was already blocked because there was no allow port 80 traffic rule).

          Well, now I have another problem. After implementing your article, I now have error 3005 showing up in Event Viewer. The text of the error follows:

          Unexpected Exchange mailbox Server error: Server: [myserver.mydomain.com] User: [[email protected]] HTTP status code: [409]. Verify that the Exchange mailbox Server is working correctly.

          For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

          FYI, I am the only user using OMA right now until I get the kinks worked out, and I still seem to be sending and receiving email fine. Also, RPC over HTTPS still seems to be working as well.

          Thanks again for all of the assistance.

          Edgar

          Comment


          • #6
            Re: Error 3029, even though OMA works!!?!

            That is quite a common error, but there is no single solution to the fix.
            The most common reason for it is where you have two domains in Exchange, for example domain.local and domain.com (where domain.local is the same name as the Windows domain) but the user account does not have an email address in the domain.local domain.

            When you created the virtual directories as per my article or the KB article, they are case sensitive. You do need to ensure that the case is correct.

            Some people have reported that checking the heartbeat interval as per this KB article can have an effect:

            http://support.microsoft.com/Default.aspx?kbid=905013

            Simon.
            --
            Simon Butler
            Exchange MVP

            Blog: http://blog.sembee.co.uk/
            More Exchange Content: http://exchange.sembee.info/
            Exchange Resources List: http://exbpa.com/
            In the UK? Hire me: http://www.sembee.co.uk/

            Sembee is a registered trademark, used here with permission.

            Comment

            Working...
            X