Announcement

Collapse
No announcement yet.

Cant get RPC over HTTP to work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cant get RPC over HTTP to work

    Hi there

    I have the following setup a SBS 2003 SP2 server
    Exchange 2003 SP2

    one server site

    For my comms I use a sonicwall TZ 170

    I have OWA setup and working using the following address

    https://webmail.mycompany.com/exchange

    also when ping webmail.mycompany.com It resolves this to my public IP address

    From here I can login and access my mail, proving my HTTPS rules is working ok?

    I have followed the document on configuring RPC over HTTP/ HTTPS from this site and cant get it to work

    If there something silly im missing??

    Many Thanks & happy Christmas
    Last edited by techirl; 25th December 2007, 23:49.
    Upgrade your Windows Vista to Windows XP Pro

  • #2
    Re: Cant get RPC over HTTP to work

    More information needed, please....
    Which Outlook Client -- needs to be 2003 upwards
    Self certificate or 3rd party?

    When you run outlook.exe /rpcdiag, what do you see?
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Cant get RPC over HTTP to work

      Hi there sorry for the lack of info

      Im using self certs, I have put some links to the errors im getting

      All working OK when I have a VPN to site and can access mail no bothers and the outlook.exe /rpcdiag works fine

      When I disconnect the tunnel I cant access any e-mail

      Im using Outlook 2007, also I have tried with Outlook 2003

      result after running outlook.exe diag using VPN



      Outlook settings




      When I disconnect the VPN link and open Outlook



      when I run Outlook.exe /rpcdiag



      Many Thanks
      Upgrade your Windows Vista to Windows XP Pro

      Comment


      • #4
        Re: Cant get RPC over HTTP to work

        Can you double check port forwarding on your router -- port 443 should be forwarded to the SBS

        Have you re-run the Internet and Email Wizard?
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Re: Cant get RPC over HTTP to work

          I have just checked this and have the following rule

          from Wan to LAn 443 ( https ) LAN IP 192.168.1.5

          I reckon I have just missed something very small but can suss it out

          DO I need to install the self cert on the Pc im trying to access from off the LAN

          Thanks again
          Upgrade your Windows Vista to Windows XP Pro

          Comment


          • #6
            Re: Cant get RPC over HTTP to work

            Is the PC a domain member? I assume it is, in which case you should not need to install the cert.

            btw, it is worth using e.g. GoDaddy to by a cheap commercial certificate (c. $20 per year)

            How did you set up RPC -- using the wizard or using the instructions here?
            Tom Jones
            MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
            PhD, MSc, FIAP, MIITT
            IT Trainer / Consultant
            Ossian Ltd
            Scotland

            ** Remember to give credit where credit is due and leave reputation points where appropriate **

            Comment


            • #7
              Re: Cant get RPC over HTTP to work

              NO the Pc is just a workgroup PC, I have I use the instructions from this site,

              I changed the IIS setting for the RPC, I modified the Exchnage settings and accepted the error as stated

              I would really love to get this working

              Are the Go Daddy certs per domain?

              Thanks
              Again
              Upgrade your Windows Vista to Windows XP Pro

              Comment


              • #8
                Re: Cant get RPC over HTTP to work

                I have followed the document again and dont seem to have missed any steps

                Im totally confussed now
                Upgrade your Windows Vista to Windows XP Pro

                Comment


                • #9
                  Re: Cant get RPC over HTTP to work

                  I never recommend the use of self generated SSL certificates with this feature. I have spent hours trying to get it to work and have failed. Purchase a certificate and I can get it to work in less than 30 minutes. GoDaddy have SSL certificates for USú20/year, you could also look at RapidSSL whose certificates are inexpensive as well. They also have a 30 day trial certificate which you could use to test with.

                  In most cases RPC over HTTPS fails for one of three reasons.

                  - certificates issues
                  - authentication problems
                  - registry settings.

                  For the certificate issues, on the client browse to https://host.domain.com/rpc
                  If you get a certificate prompt then the feature will not work.

                  For the authentication issues, ensure that you are using the same authentication setting on the virtual directory and in Outlook. If the /rpc virtual directory in IIS manager is set to use basic then you need to set Basic in Outlook. If it is set to use integrated then use NTML in Outlook.

                  For the registry settings, a common error is not making the registry setting on the domain controller. Otherwise you need to ensure that they are correct. Daniel Petri and myself disagree on what settings are required, my version is at http://www.amset.info/exchange/rpc-http.asp

                  Simon.
                  --
                  Simon Butler
                  Exchange MVP

                  Blog: http://blog.sembee.co.uk/
                  More Exchange Content: http://exchange.sembee.info/
                  Exchange Resources List: http://exbpa.com/
                  In the UK? Hire me: http://www.sembee.co.uk/

                  Sembee is a registered trademark, used here with permission.

                  Comment


                  • #10
                    Re: Cant get RPC over HTTP to work

                    Anyone else got any Ideas?
                    Upgrade your Windows Vista to Windows XP Pro

                    Comment


                    • #11
                      Re: Cant get RPC over HTTP to work

                      I would suggest to follow Simons advice
                      He's a real guru about exchange.
                      Marcel
                      Technical Consultant
                      Netherlands
                      http://www.phetios.com
                      http://blog.nessus.nl

                      MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
                      "No matter how secure, there is always the human factor."

                      "Enjoy life today, tomorrow may never come."
                      "If you're going through hell, keep going. ~Winston Churchill"

                      Comment


                      • #12
                        Re: Cant get RPC over HTTP to work

                        if you want to use RPC over HTTPS just make sure to run the tool provided here:
                        http://www.petri.com/software/rpcnofrontend.zip together with http://www.petri.com/configure_rpc_o...gle_server.htm

                        The guide helped me setup RPC over HTTPS properly, though without the use of the rpcnofrontend tool it did not work either.
                        Make sure you setup the RPC ports properly by including the internet address to your exchange server.

                        Setup here at work is Sonicwall PRO 330, forwarded 80 & 443 to the Exchange server in the LAN.

                        if you need some assistance I am probably able to help out

                        Comment

                        Working...
                        X