Announcement

Collapse
No announcement yet.

ActiveSync not showing new messages on phone

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ActiveSync not showing new messages on phone

    Hi everybody,

    I've a problem that is driving me nuts! I've Windows SBS 2003 Standard SP2 with GFI mailessentials as pop3 connector installed and when i try to use activesync on my samsung sgh-i 600 the phone is not showing new messages. The sync shows that there are new messages, when syncing but after done no message shows up in the inbox folder. But if i login with OWA or just do a checkmail in outlook 2003, i see those new messages and then if i sync again my phone those messages shows up in the phone too. I've even configured an imap account on the phone to the same server, that is working with no sort of problem. It seems that with the phone, i can only view the messages present on my inbox on the exchange server, only if i use first OWA or outlook or the imap account i've created on the phone. Than using activesync the same messages i already see with those previous tools, appear in the inbox folder.

    Both OWA and Outlook 2003 with RPC over http, work from outside my office, i've just this problem with activesync and my phone. Now i'm using an imap account created on the phone, but i would like to use activesync future instead. Activesync is not giving any sort of error messages, it just not show new messages if i don't use those tools before.

    Any suggestions? Thanks a lot.

  • #2
    Re: ActiveSync not showing new messages on phone

    No one can help me....?

    Comment


    • #3
      Re: ActiveSync not showing new messages on phone

      let me get this straight cuz i read your post three times.

      IF you open owa or view your new mail in anyway THEN
      active synch works
      ELSE
      active synch does not show new mail
      END IF


      I notice that you have owa. why are you creating a pop3 account to push email thru your phone? that's another question, but it's not important right now.

      Have you tested with another phone? It helps because it will distinguish rather it's your phone or not. I have the same setup as you. exchange 2003 with GFI. Did you check your Exchanger Manager to see if that user can use a mobile account? I just setup 20 users with windows mobile and they are getting their email without the added steps.

      Comment


      • #4
        Re: ActiveSync not showing new messages on phone

        Hi! Thanks for replying. I've done this test today:

        From pc and from phone, using a browser(both from lan and wan):

        https://myserver.mydomain.com/oma
        Opens my inbox in hypertext and it does show all new messages both new and old one. If i send a new email i see it as soon as it arrive.

        https://myserver.mydomain.com/Micros...ver-Activesync
        Gives me the right error page, indicating that oma works ok (as posted also in this site).

        https://myserver.mydomain.com/Exchange
        Works to.

        Outlook on mobile clients, configured with rpc over http, works too. Both in the office and when they are on the road.

        But! If i try to use, (tested on two different windows mobile phone), activesync to sync email to my phone, it does work in the sense that it download all the stuff i want. But if i then send a new email, and try to resync, the phone does not show the new message if i don't run before outlook clien,t or using owa with a browser, and only after that if i resync the message appear on the phone.

        What do you mean "you creating a pop3 account"?

        Thanks again.

        Comment


        • #5
          Re: ActiveSync not showing new messages on phone

          Any reason you are using a POP3 connector instead of SMTP delivery? If you are using OWA, RPC over HTTPS etc then you must have a permanent connection to the internet with some form of static IP address or dynamic DNS solution in place. I would suggest switching to SMTP delivery to begin with - without using SMTP delivery I personally feel that push is a waste of time, because you only get email at regular intervals - not as it arrives - you may as well configure the device to sync on a schedule rather than push.

          I have seen references to this problem in the past, but it is not something that I have seen before. As you haven't deployed Exchange as it was designed, that would be the first place I would be looking at for a source of the problem.

          Simon.
          --
          Simon Butler
          Exchange MVP

          Blog: http://blog.sembee.co.uk/
          More Exchange Content: http://exchange.sembee.info/
          Exchange Resources List: http://exbpa.com/
          In the UK? Hire me: http://www.sembee.co.uk/

          Sembee is a registered trademark, used here with permission.

          Comment


          • #6
            Re: ActiveSync not showing new messages on phone

            Hi! I'm waiting to switch from pop3 to smtp delivery. This is a new customer, and this configuration was already in place. I'm not using push tecnology, because we don't have any deal with gsm carrier, but just using normal activesync manual or automatic. Do you think that switching to smtp delivery, could really solve the issue?

            Because by doing those tests, i would suppose that the configuration is ok.

            Thanks.

            Comment


            • #7
              Re: ActiveSync not showing new messages on phone

              If you have phone service on the device then you will have a connection with the mobile phone company. ActiveSync/Push doesn't require anything more than data service to be enabled.

              Are you synchronising over the air or via docking and using ActiveSync.

              I am not entirely convinced that Exchange and ActiveSync is either configured or being used correctly.

              Simon.
              --
              Simon Butler
              Exchange MVP

              Blog: http://blog.sembee.co.uk/
              More Exchange Content: http://exchange.sembee.info/
              Exchange Resources List: http://exbpa.com/
              In the UK? Hire me: http://www.sembee.co.uk/

              Sembee is a registered trademark, used here with permission.

              Comment


              • #8
                Re: ActiveSync not showing new messages on phone

                I'm synchronizing with gprs/edge/umts. I meant directpush, using sms. For that, if I'm not wrong you need a carrier contract. But maybe I'm wrong. Anyway, apart that problem everything is working fine with exchange, is just a matter of switching to smtp direct delivery, and see if that problem goes away. Because i don't have anymore checkings to try.....

                But the problem is very strange, don't you think?

                Comment


                • #9
                  Re: ActiveSync not showing new messages on phone

                  DirectPush is a dead technology. It used SMS messages which basically meant it was useless to anyone outside the USA where we have to pay for text messages that are sent and free email to SMS gateways do not exist.
                  Push email from Exchange 2003 SP2 on uses HTTP for synchronisation.

                  Do you have the server fully up to date - including Exchange 2003 SP2?

                  Simon.
                  --
                  Simon Butler
                  Exchange MVP

                  Blog: http://blog.sembee.co.uk/
                  More Exchange Content: http://exchange.sembee.info/
                  Exchange Resources List: http://exbpa.com/
                  In the UK? Hire me: http://www.sembee.co.uk/

                  Sembee is a registered trademark, used here with permission.

                  Comment


                  • #10
                    Re: ActiveSync not showing new messages on phone

                    Ok. On System Manager i read: version 6.5 (build 7638.2: Service Pack 2)

                    The system is a SBS 2003 Standard Italian, basic form auth activated, oma and unsupported device activated, Directpush via http activated.

                    Any other info?

                    Comment


                    • #11
                      Re: ActiveSync not showing new messages on phone

                      Have the devices been hard reset?
                      Have you tried using the emulator to see if the problem is device specific?

                      Simon.
                      --
                      Simon Butler
                      Exchange MVP

                      Blog: http://blog.sembee.co.uk/
                      More Exchange Content: http://exchange.sembee.info/
                      Exchange Resources List: http://exbpa.com/
                      In the UK? Hire me: http://www.sembee.co.uk/

                      Sembee is a registered trademark, used here with permission.

                      Comment


                      • #12
                        Re: ActiveSync not showing new messages on phone

                        Hi, the device is fresh new. What is the emulator?

                        Comment


                        • #13
                          Re: ActiveSync not showing new messages on phone

                          The device being fresh new doesn't really matter. If you have tried to configure it then reset it. The emulator is exactly that - Windows Mobile emulator. It is a free download from Microsoft.

                          Simon.
                          --
                          Simon Butler
                          Exchange MVP

                          Blog: http://blog.sembee.co.uk/
                          More Exchange Content: http://exchange.sembee.info/
                          Exchange Resources List: http://exbpa.com/
                          In the UK? Hire me: http://www.sembee.co.uk/

                          Sembee is a registered trademark, used here with permission.

                          Comment


                          • #14
                            Re: ActiveSync not showing new messages on phone

                            http://www.microsoft.com/downloads/d...displaylang=en
                            cheers
                            Andy

                            Please read this before you post:


                            Quis custodiet ipsos custodes?

                            Comment

                            Working...
                            X