No announcement yet.

RPC over HTTPS mail=https directory=tcp/ip

  • Filter
  • Time
  • Show
Clear All
new posts

  • RPC over HTTPS mail=https directory=tcp/ip

    I have followed the guides and have got it working, the only problem is when I look at connection status of outlook, mail is connecting with HTTPS but directory is still using TCP/IP (see attachment)

    When I connect from the web everything seems to be working and I can send and receive e-mail and access the Global address list although it says directory is disconnected.

    My setup is.
    Server2003 running,
    RPC Proxy installed.
    CA Server
    This is a member server on the domain.

    Any help or advice would be greatly appreciated.
    Attached Files
    Last edited by DavidHole; 20th November 2007, 23:04.

  • #2
    Re: RPC over HTTPS mail=https directory=tcp/ip

    In Outlook email configuration, where you specify the RPC/HTTPS server, there is an option to "on fast connections use TCP/IP" or similar phrasing -- check what that is set as

    I would suggest "the proof of the pudding is in the eating" If you are receiving emails from outwith your LAN, it is working!
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    IT Trainer / Consultant
    Ossian Ltd

    ** Remember to give credit where credit is due and leave reputation points where appropriate **


    • #3
      Re: RPC over HTTPS mail=https directory=tcp/ip

      It is turned on for slow and fast networks.

      Did some testing last night and my laptop was fine I could send and receive mail all night.

      The only problem was creating a new mail account, from my tests outlook needs to be connected to exchange when you first setup the mail profile, I think this is due to it not being able to connect to directory when on an external network.

      Does this sound right?



      • #4
        Re: RPC over HTTPS mail=https directory=tcp/ip

        If it is connecting to the directory on TCP/IP that could be:

        - you specified the wrong domain controller in the registry settings, or made a typo
        - you haven't made the registry change to the domain controller
        - the domain controller isn't a global catalog
        - the domain controller isn't Windows 2003.

        You should be able to configure RPC over HTTPS outside the network without being connected to the network. That is how hosted Exchange providers work. However if you cannot connect to the domain controller over HTTPS as already outlined then it will not work.

        Simon Butler
        Exchange MVP

        More Exchange Content:
        Exchange Resources List:
        In the UK? Hire me:

        Sembee is a registered trademark, used here with permission.


        • #5
          Re: RPC over HTTPS mail=https directory=tcp/ip

          I have confirmed the ports on the exchange server.

          C:\Documents and Settings\davidh>rpccfg /hd
          Server Name Port Settings
          exchange2 100-5000 593 6001-6002 6004
          exchange2.pc-posuk.local 593 6001-6002 6004
 593 6001-6002 6004
          win2kserver3 593 6001-6002 6004
          win2kserver3.pc-posuk.local 593 6001-6002 6004

          and have confirmed the DC is a GC server
          and have made the following registry change to the DC

          [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\NTDS\Parameters]
          "NSPI Interface protocol sequences"=hex(7):6e,00,63,00,61,00,63,00,6e,00,5f ,00,\
          68,00,74,00,74,00,70,00,3a,00,36,00,30,00,30,00,34 ,00,00,00,00,00

          Directory is still conecting with tcpip, any more sugestions?