Announcement

Collapse
No announcement yet.

RPC over HTTP doesnt work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RPC over HTTP doesnt work

    Hi

    I read your article in some parts is similar thew only thing that doesn't is that i have an dexchange server and a Domain server. so in the part of the regristry y move things how i see it at the point where NTDS/Parameters only appears on DC.

    i have a firewall witch i open ports for the RPC over HTTP, but when i trie to connec it ask me user an pass but when i put it fails.

    i don't know whats going wrong

    if i need that my exchange server convert to global catalog server or if i have something wrong in my configuration of the IIS

    help me

  • #2
    Re: RPC over HTTP doesn't work

    First - do you meet the requirements for RPC over HTTPS?

    Exchange 2003 on a Windows 2003 server, with at least one Windows 2003 DC/GC. Client must be Windows XP with Outlook 2003 or higher.

    Next. Is the Exchange server currently a domain controller or not? If it is NOT, then DO NOT make it a domain controller. That is not the fix for the problem and will only cause you further issues.
    If it is a domain controller, then is it also a global catalog?

    Next. The most common reason for this feature to fail is SSL certificate issues. SSL certificates are not optional for this feature. Therefore you need to ensure that your certificate is trusted by the client. Browse to https://host.domain.com/rpc - if you get an SSL certificate prompt then the feature will not work. You need to resolve the certificate issue - usually by purchasing an SSL certificate. You can get those for US$20 - $60 if you look around - as a test get one from RapidSSL as they have trusted 30 day trial certificates.

    Next. Ensure that the authentication types that you are using are the same - Basic and basic on the RPC virtual directory in IIS manager or NTLM/Integrated. You can enable both. If you have to change it, run iisreset from a command prompt before continuing.

    Finally, registry settings. There are various versions of these floating around. Daniel has his, I have mine. My settings are at http://www.amset.info/exchange/rpc-http.asp
    Remember there is a registry setting to be applied to both the Exchange server and the domain controller/s.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: RPC over HTTP doesnt work

      i was going to make it DC/GC cuz allo fthis it's getting me nuts. the reason i'm doing this is cuz i have a Cuda 300 antispam so my clients that have POP3 are getting like deferred or queue stuff, so i'm trying this one of RPC over HTTP to make them connect as if they where on my LAN so the cuda dont do that to their mails

      i 'll read your article from the link that you put

      10xs hope it works.

      Comment


      • #4
        Re: RPC over HTTP doesnt work

        i'm going to kill my self my model off how it is setup all make me go wrong.

        leaving this for monday need to clear my mind.

        i got to the process of authentication in outlook but when i put the user and pass it gets to there a do nothing i check out the conection status only exchange i can see but my DC connection are in blank

        what can it be

        my topology and i know that your going to get mad but my boss insisted to put it like this

        i have wan 1 for internet and wan 2 exclusiveli to mail then all pass to my firewall(fortigate 100a)then the mother of all errors i got my exchange server in a DMZ (ideas from my boss and you know how it is), and i don;t know how to make the connection from outside to see my dns and exchange so RCP over HTTP works

        any idea.


        HOPE i can put it back to my internal lan my server but this is actual model

        Comment


        • #5
          Re: RPC over HTTP doesn't work

          Exchange in a DMZ is a bad idea. And while you have Exchange server in that location you will continue to have problems with the server operating.
          I would suggest that you and your boss read this posting on my blog about Exchange in a DMZ: http://www.sembee.co.uk/archive/2006/02/23/7.aspx
          Then ask the question how it improves the security of your network? It doesn't.

          You need to get RPC over HTTPS working internally first. However if the Exchange server cannot communicate with the domain controller correctly then it will not work.

          You really need to sort out the network design first - while you have the current topology you will continue to get problems.

          Making the Exchange server a domain controller is NOT a solution. That will probably damage your Exchange server and is an unsupported action.

          Simon.
          --
          Simon Butler
          Exchange MVP

          Blog: http://blog.sembee.co.uk/
          More Exchange Content: http://exchange.sembee.info/
          Exchange Resources List: http://exbpa.com/
          In the UK? Hire me: http://www.sembee.co.uk/

          Sembee is a registered trademark, used here with permission.

          Comment


          • #6
            Re: RPC over HTTP doesnt work

            When setting up our RPC-HTTP we found the laptops would not connect, we could put in the username and pass but nothing would happen.

            It was only till we put them onto the network and connected them to exchange in the traditional way did it then work.

            Dave

            Comment


            • #7
              Re: RPC over HTTP doesn't work

              You don't have to connect Outlook clients to the same network to get RPC over HTTPS to work. The feature is designed so that external machines can connect - that is how Hosted Exchange providers work.
              It is a little more fiddly to get it to work for external users, which Autodiscover on Exchange 2007 is supposed to improve on. However it can be done.

              Simon.
              --
              Simon Butler
              Exchange MVP

              Blog: http://blog.sembee.co.uk/
              More Exchange Content: http://exchange.sembee.info/
              Exchange Resources List: http://exbpa.com/
              In the UK? Hire me: http://www.sembee.co.uk/

              Sembee is a registered trademark, used here with permission.

              Comment

              Working...
              X