No announcement yet.

“waiting to update this folder”

  • Filter
  • Time
  • Show
Clear All
new posts

  • “waiting to update this folder”

    Hi guys,
    Since one week everything was running fine until today.

    I have Exchange 2003 SP2 running Windows 2003 SP2 and just yesterday and today when I open the outlook it connect to exchange and then a message appear in the right button saying “waiting to update this folder” then it take more than 5 minutes to get all e-mail from server.

    My outlook in cached mode, I remove the cached and try to open the outlook it hang for 5 minutes then It get all my e-mails. I put the cached mode again and the message appear again “waiting to update this folder”.

    This is a common thing is all users using outlook 2003 / 2007-09-16

    Please help me..

  • #2
    Re: “waiting to update this folder”

    guys any help........


    • #3
      Re: “waiting to update this folder”

      I have been wrestling with exactly the same problem for some time, and haven't found any other solutions or explanation.

      However, I can share a couple of workarounds and other things I've noticed which hopefully can help...

      First scenario:

      Currently, my Outlook (2003) resynchronises correctly on startup and shutdown, but gets into the "waiting to update..." state soon after and is out of sync from then on. To force an update, the only effective way I've found (without restarting Outlook) is to disconnect (click "Connected" in the status bar and select "Work Offline"), the reconnect. This (currently) works for me in the state Outlook is in.

      To get back into this "waiting" state, I just need to browse a sub-folder of Inbox, then return ti Inbox top level. There is then no way out of this state without disconnect/reconnect to the server, or Outlook restart.

      Second scenario:

      I have had Outlook in the same state, but where disconnect / reconnect had no effect, and neither did restarting Outlook! In this case, I discovered that changing the Exchange Server Settings to NOT use cached mode (temporarily), then restarting Outlook, setting cached mode back on, and restarting again fixed the problem. Outlook still stores the cache file, so nothing is lost (cache doesn't need rebuilding from scratch), yet synchronisation was restored.

      I have not been able to regularly reproduce getting into this state.

      Third scenario:

      Once, Outlook was in this state and seemed completely unable to synchronise the cache. Only rebuilding the cache seemed to solve this: deselect cached mode; restart Outlook; find and delete (or rename the cache file; re-enable cached mode; restart Outlook; wait for it to rebuild the cache (may take a while...

      Does anyone have any ideas on the root cause of Oulook's cache synchronisation problems (how it gets into this state and why)?