No announcement yet.

IMF Catching Internal mail

  • Filter
  • Time
  • Show
Clear All
new posts

  • IMF Catching Internal mail


    A bit of a weird one here.

    We've got Exchange 2003 with IMF V2 running on it. We also have a xerox printer (capable of sending emails). There is also a mailbox for the printer.

    However, all mails from the xerox to any other local email is being caught in the IMF as spam.

    I enabled connection filtering and put the following addresses in the Global Accept List: ( - Local subnet
    and the IP of the printer (

    Still doesn't seem to be helping.

    Would appreciate if I could get some ideas!


  • #2
    Re: IMF Catching Internal mail

    Pull the email out of the IMF and look at the headers. What ip is the email coming from, the internal or an external ip? Here is what I suspect: the xerox is sending mail but it doesn't know anything about AD, Exchange, etc. It is doing an MX lookup for your domain and finding the public ip of your mail server (because you don't have an internal MX for your Exchange server because it's not needed) so the xerox is sending the email out through your firewall to the public ip of your Exchange server so the email hits the IMF with a public ip not the internal ip. If this is the case then add the public ip to the IMF or create an internal MX for your Exchange server (which won't cause any problem for Exchange server). Make sure that the xerox is configured to use your internal DNS server(s).
    Last edited by joeqwerty; 27th July 2007, 04:18.


    • #3
      Re: IMF Catching Internal mail

      This is very common.
      What I do when this starts happening is put an additional internal IP address on to the server. Then change the default SMTP virtual server to be bound to the primary IP address only. Once changed, a second SMTP virtual server is then created and bound to the new second internal IP address.
      This second SMTP vs does not have IMF enabled on it. All internal resources are then pointed at this second SMTP VS for sending email internally.
      No need to change any filtering or other settings which could cause other problems or reduce your security.

      Simon Butler
      Exchange MVP

      More Exchange Content:
      Exchange Resources List:
      In the UK? Hire me:

      Sembee is a registered trademark, used here with permission.


      • #4
        Re: IMF Catching Internal mail

        I would just like to add a remark to Simon's reply - YOU need to do all that, it is not just created and configured automatically for you...

        Daniel Petri
        Microsoft Most Valuable Professional - Active Directory Directory Services